aboutsummaryrefslogtreecommitdiffstats
path: root/mail/moztraybiff
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2005-05-18 06:15:23 +0800
committeradamw <adamw@FreeBSD.org>2005-05-18 06:15:23 +0800
commit4d4dddc23b7cbe51423eaa490e5377e980dc0d84 (patch)
tree43c1dc40bf673336ea156714f67ec442ed35c31f /mail/moztraybiff
parent28cc0bc2a32968d0d68d9d6016de6d98bc140e0a (diff)
downloadfreebsd-ports-gnome-4d4dddc23b7cbe51423eaa490e5377e980dc0d84.tar.gz
freebsd-ports-gnome-4d4dddc23b7cbe51423eaa490e5377e980dc0d84.tar.zst
freebsd-ports-gnome-4d4dddc23b7cbe51423eaa490e5377e980dc0d84.zip
Update to 1.1.
Please keep in mind that new versions of this thing just install a new .xpi file in ${DATADIR}. To upgrade, you must uninstall the old version (via the extensions manager thinger), restart thunderbird, install the new version, and then restart thunderbird again. This info would be useful in /usr/ports/UPDATING, but I'm hesitant to put it in there for every release.
Diffstat (limited to 'mail/moztraybiff')
-rw-r--r--mail/moztraybiff/Makefile5
-rw-r--r--mail/moztraybiff/distinfo4
-rw-r--r--mail/moztraybiff/files/patch-Makefile8
-rw-r--r--mail/moztraybiff/files/patch-components_Makefile15
4 files changed, 23 insertions, 9 deletions
diff --git a/mail/moztraybiff/Makefile b/mail/moztraybiff/Makefile
index 3241032fa480..e4d2e30839c1 100644
--- a/mail/moztraybiff/Makefile
+++ b/mail/moztraybiff/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= moztraybiff
-PORTVERSION= 1.0.7
-PORTREVISION= 2
+PORTVERSION= 1.1
CATEGORIES= mail gnome
MASTER_SITES= http://mozdev.oregonstate.edu/moztraybiff/
DISTNAME= mozTrayBiff-${PORTVERSION}
@@ -29,7 +28,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= libgnome
USE_REINPLACE= yes
-MAKE_ARGS+= MOZILLA_PLATFORM=tbird
+MAKE_ARGS+= MOZILLA_PLATFORM=tbird TBVER=${TBVER}
FILENAME= mozTrayBiff-${PORTVERSION}-FreeBSD-tb${TBVER}.xpi
PLIST_FILES= share/${PORTNAME}/${FILENAME}
diff --git a/mail/moztraybiff/distinfo b/mail/moztraybiff/distinfo
index b95d28727eca..95459a4c242d 100644
--- a/mail/moztraybiff/distinfo
+++ b/mail/moztraybiff/distinfo
@@ -1,2 +1,2 @@
-MD5 (mozTrayBiff-1.0.7.tar.gz) = 42905cec4b680ba888e6c8e32521fb66
-SIZE (mozTrayBiff-1.0.7.tar.gz) = 29267
+MD5 (mozTrayBiff-1.1.tar.gz) = 156bbd58545b602ddfe735605a3711d0
+SIZE (mozTrayBiff-1.1.tar.gz) = 33038
diff --git a/mail/moztraybiff/files/patch-Makefile b/mail/moztraybiff/files/patch-Makefile
index 5b8c43a334f6..404cae85b158 100644
--- a/mail/moztraybiff/files/patch-Makefile
+++ b/mail/moztraybiff/files/patch-Makefile
@@ -1,15 +1,15 @@
---- Makefile.orig Sat Mar 19 22:29:01 2005
-+++ Makefile Sat Mar 19 22:30:04 2005
+--- Makefile.orig Tue May 17 17:48:26 2005
++++ Makefile Tue May 17 17:49:09 2005
@@ -1,7 +1,7 @@
SUBDIRS = components chrome
.PHONY: all clean subdirs ${SUBDIRS} content locale
- VERSION = 1.0.7
+ VERSION = 1.1
-PLATFORM := $(shell gcc -dumpmachine)
+PLATFORM := $(shell uname)
XPI_NAME = mozTrayBiff
XPI_VERSION := $(VERSION)-$(PLATFORM)
XPI_FILENAME = $(XPI_NAME)-$(XPI_VERSION).xpi
-@@ -15,7 +15,7 @@
+@@ -15,7 +15,7 @@ XPI_VERSION := $(XPI_VERSION)-moz$(shell
XPI_EXTRA_FILES = install.js
endif
ifeq ($(MOZILLA_PLATFORM),tbird)
diff --git a/mail/moztraybiff/files/patch-components_Makefile b/mail/moztraybiff/files/patch-components_Makefile
new file mode 100644
index 000000000000..7f744d234f67
--- /dev/null
+++ b/mail/moztraybiff/files/patch-components_Makefile
@@ -0,0 +1,15 @@
+--- components/Makefile.orig Sun Apr 24 10:25:02 2005
++++ components/Makefile Tue May 17 18:08:15 2005
+@@ -69,10 +69,10 @@ ${COMPONENT_NAME}.xpt: nsIMessengerFreeD
+ LD_LIBRARY_PATH=$(MOZILLA_UTIL_PREFIX):`pwd` $(MOZILLA_UTIL_PREFIX)/xpt_link $@ $<
+
+ %.xpt: %.idl
+- LD_LIBRARY_PATH=$(MOZILLA_UTIL_PREFIX):`pwd` $(MOZILLA_UTIL_PREFIX)/xpidl $(MOZILLA_IDLFLAGS) -m typelib -e $@ $<
++ LD_LIBRARY_PATH=$(MOZILLA_UTIL_PREFIX):`pwd` $(MOZILLA_UTIL_PREFIX)/xpidl $(MOZILLA_IDLFLAGS) -I$(shell thunderbird-config --prefix)/share/idl/thunderbird-$(TBVER) -m typelib -e $@ $<
+
+ %.h: %.idl
+- LD_LIBRARY_PATH=$(MOZILLA_UTIL_PREFIX):`pwd` $(MOZILLA_UTIL_PREFIX)/xpidl $(MOZILLA_IDLFLAGS) -m header -e $@ $<
++ LD_LIBRARY_PATH=$(MOZILLA_UTIL_PREFIX):`pwd` $(MOZILLA_UTIL_PREFIX)/xpidl $(MOZILLA_IDLFLAGS) -I$(shell thunderbird-config --prefix)/share/idl/thunderbird-$(TBVER) -m header -e $@ $<
+
+ nsIMessengerFreeDesktopIntegration.xpt: nsIMessengerFreeDesktopIntegration.idl
+