aboutsummaryrefslogtreecommitdiffstats
path: root/mail/msmtp
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2011-07-05 18:47:20 +0800
committernovel <novel@FreeBSD.org>2011-07-05 18:47:20 +0800
commit04595a6c9c0e4207a2445a749e948922ece9f91e (patch)
tree0e45053374131b90cfb840400d10f274fafa9cf8 /mail/msmtp
parent1763a0eeab28b82e443a7e9faec66428abcb185b (diff)
downloadfreebsd-ports-gnome-04595a6c9c0e4207a2445a749e948922ece9f91e.tar.gz
freebsd-ports-gnome-04595a6c9c0e4207a2445a749e948922ece9f91e.tar.zst
freebsd-ports-gnome-04595a6c9c0e4207a2445a749e948922ece9f91e.zip
- Pet portlint(1)
- Introduce GNOME_KEYRING option PR: 158596 (based on) Submitted by: jlaffaye
Diffstat (limited to 'mail/msmtp')
-rw-r--r--mail/msmtp/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/mail/msmtp/Makefile b/mail/msmtp/Makefile
index 63860f29cc90..26dfe95b30ce 100644
--- a/mail/msmtp/Makefile
+++ b/mail/msmtp/Makefile
@@ -14,21 +14,21 @@ MASTER_SITES= SF
MAINTAINER= novel@FreeBSD.org
COMMENT= SMTP plugin for MUAs
+LICENSE= GPLv3
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= msmtp.1
INFO= msmtp
-LICENSE= GPLv3
-
OPTIONS= GNUTLS "Adds GnuTLS support" off \
OPENSSL "Adds support for SSL (Secure Socket Layer)" on \
GSASL "Adds GSASL support" off \
NLS "Native Language Support via gettext utilities" on \
IDN "Enable Internationalized Domain Names" on \
+ GNOME_KEYRING "Build with GNOME Keyring auth support" off
.include <bsd.port.options.mk>
@@ -61,6 +61,13 @@ CONFIGURE_ARGS+= --with-libidn
CONFIGURE_ARGS+= --without-libidn
.endif
+.if !defined(WITH_GNOME_KEYRING)
+CONFIGURE_ARGS+= --without-gnome-keyring
+.else
+CONFIGURE_ARGS+= --with-gnome-keyring
+LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-nls