aboutsummaryrefslogtreecommitdiffstats
path: root/mail/msmtpqueue/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-06-22 05:35:58 +0800
committerpav <pav@FreeBSD.org>2004-06-22 05:35:58 +0800
commit557d77d0a619e79f1d795ffd18204ba6a230fdc6 (patch)
tree34aed21ffb22c03574b208cb5c3c2b3a0b8ef236 /mail/msmtpqueue/Makefile
parentef1de578764208d7432f3318b9dd96bda2db51b8 (diff)
downloadfreebsd-ports-gnome-557d77d0a619e79f1d795ffd18204ba6a230fdc6.tar.gz
freebsd-ports-gnome-557d77d0a619e79f1d795ffd18204ba6a230fdc6.tar.zst
freebsd-ports-gnome-557d77d0a619e79f1d795ffd18204ba6a230fdc6.zip
Add msmtpqueue, a set of scripts to help queueing and sending mails
on non-permanent connections like dial-up using msmtp. PR: ports/68055 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
Diffstat (limited to 'mail/msmtpqueue/Makefile')
-rw-r--r--mail/msmtpqueue/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/mail/msmtpqueue/Makefile b/mail/msmtpqueue/Makefile
new file mode 100644
index 000000000000..b7b7bbe0a158
--- /dev/null
+++ b/mail/msmtpqueue/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: msmtpqueue
+# Date created: 2004-06-17
+# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= msmtpqueue
+PORTVERSION= 0.3
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= msmtp
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= Scripts to queue mails with msmtp
+
+RUN_DEPENDS= msmtp:${PORTSDIR}/mail/msmtp
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/msmtp-enqueue.sh bin/msmtp-runqueue.sh
+PORTDOCS= README
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/msmtp-enqueue.sh ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/msmtp-runqueue.sh ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>