aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt-devel/Makefile
diff options
context:
space:
mode:
authorjim <jim@FreeBSD.org>2002-03-12 06:34:12 +0800
committerjim <jim@FreeBSD.org>2002-03-12 06:34:12 +0800
commitab2a52169f70cfd0b9ac76efdec45d6862885ae7 (patch)
treefd4b953d8aea07ca1672aa4c763aaf3405cd048b /mail/mutt-devel/Makefile
parent7e8311f50e251f493a835b8176055e3f74f68416 (diff)
downloadfreebsd-ports-gnome-ab2a52169f70cfd0b9ac76efdec45d6862885ae7.tar.gz
freebsd-ports-gnome-ab2a52169f70cfd0b9ac76efdec45d6862885ae7.tar.zst
freebsd-ports-gnome-ab2a52169f70cfd0b9ac76efdec45d6862885ae7.zip
Add a MUTT_CONFIGURE_ARGS variable for adding additional config options,
and adjust the documentation to suggest /etc/make.conf as a good place to store the Makefile knobs. PR: 35731 Submitted by: maintainer
Diffstat (limited to 'mail/mutt-devel/Makefile')
-rw-r--r--mail/mutt-devel/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 94935ef19137..1bef567dd63a 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -5,9 +5,19 @@
#
# $FreeBSD$
#
-
# There are several knobs which are used to define additions to the core
-# mutt functionality. The two most important are:
+# mutt functionality.
+#
+# As all of the knobs have a unique name which should not interfere with
+# other ports you can add them to /etc/make.conf, e.g. a line like
+# "WITH_MUTT_HTML=yes" will enable mutt's HTML documentation.
+#
+# In addition to the knobs listed below you can enable other configuration
+# options of mutt by adding them to the MUTT_CONFIGURE_ARGS variable. For
+# example you could say "MUTT_CONFIGURE_ARGS=--with-homespool=MyMail" to
+# configure a different directory for mutt's homespool.
+#
+# The two most important knobs are:
#
# In general you can choose between using the SLANG port (which is really
# recommended and is now the default) and ncurses (WITH_MUTT_NCURSES). If you
@@ -68,6 +78,9 @@ CONFIGURE_ARGS= --enable-flock --disable-fcntl \
--with-docdir=${PREFIX}/share/doc/mutt \
--sysconfdir=${PREFIX}/etc --enable-external-dotlock \
--with-libiconv-prefix=${PREFIX}
+.if defined(MUTT_CONFIGURE_ARGS)
+CONFIGURE_ARGS+= ${MUTT_CONFIGURE_ARGS}
+.endif
.include <bsd.port.pre.mk>