aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt-devel/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-08-29 22:06:34 +0800
committersem <sem@FreeBSD.org>2004-08-29 22:06:34 +0800
commitf6bc228c51c100809115d8bb8758ae7aacb5809d (patch)
treeb3476a24d32d53bdef5a34aff976ee85e82fed7f /mail/mutt-devel/Makefile
parent748f11c4c2ef1804716fd46a956365a3c47b5d1e (diff)
downloadfreebsd-ports-gnome-f6bc228c51c100809115d8bb8758ae7aacb5809d.tar.gz
freebsd-ports-gnome-f6bc228c51c100809115d8bb8758ae7aacb5809d.tar.zst
freebsd-ports-gnome-f6bc228c51c100809115d8bb8758ae7aacb5809d.zip
- Change the default from WITH_MUTT_NCURSES to WITH_MUTT_SLANG to be in
sync with mail/mutt. - Update the maildir header cache to the current version. - Update the threadcomplete patch (including some documentation on it). - Beautify the documentation in some cases. - Correct the note how to get SLANG working. - Bump PORTREVISION. PR: ports/71103 Submitted by: maintainer
Diffstat (limited to 'mail/mutt-devel/Makefile')
-rw-r--r--mail/mutt-devel/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 9b64be2a7951..3c689ca52e7a 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -19,9 +19,9 @@
#
# The two most important knobs are:
#
-# In general you can choose between using the SLANG port (WITH_MUTT_SLANG)
-# and ncurses (WITH_MUTT_NCURSES) which is the default. Note that you may
-# have to set the variables COLORTERM=yes and COLORFGBG=color,color in your
+# In general you can choose between using ncurses (WITH_MUTT_NCURSES)
+# and SLANG (WITH_MUTT_SLANG) which is the default. Note that you may
+# have to set the variables COLORTERM=yes and COLORFGBG="color1;color2" in your
# environment to get slang function properly.
#
# If you want to install the mutt documentation in html and ps format define:
@@ -81,7 +81,7 @@
PORTNAME= mutt-devel
PORTVERSION= 1.5.6
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES+= mail ipv6
.if defined(WITH_MUTT_NNTP)
CATEGORIES+= news
@@ -171,15 +171,15 @@ RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell \
.if defined(WITH_MUTT_NCURSES_PORT)
WITH_MUTT_NCURSES= yes
.endif
-.if defined(WITH_MUTT_NCURSES)
-MUTT_USES_NCURSES= yes
-.endif
-.if defined(WITH_MUTT_SLANG) && !defined(MUTT_USES_NCURSES)
+.if defined(WITH_MUTT_SLANG)
MUTT_USES_SLANG= yes
.endif
-.if !defined(MUTT_USES_NCURSES) && !defined(WITHOUT_MUTT_NCURSES) && !defined(MUTT_USES_SLANG)
+.if defined(WITH_MUTT_NCURSES) && !defined(MUTT_USES_SLANG)
MUTT_USES_NCURSES= yes
.endif
+.if !defined(MUTT_USES_SLANG) && !defined(WITHOUT_MUTT_SLANG) && !defined(MUTT_USES_NCURSES)
+MUTT_USES_SLANG= yes
+.endif
.if defined(WITHOUT_MUTT_SGMLFORMAT)
SGML_USED= no
.endif
@@ -399,7 +399,7 @@ post-install:
@${ECHO} "=====================================================" >> ${PKGMESSAGE}
@${ECHO} "You have installed ${PORTNAME} with SLANG support." >> ${PKGMESSAGE}
@${ECHO} "This may work for a color terminal only when defining" >> ${PKGMESSAGE}
- @${ECHO} "COLORTERM=yes and COLORFGBG=color,color in your" >> ${PKGMESSAGE}
+ @${ECHO} "COLORTERM=yes and COLORFGBG=\"color1;color2\" in your" >> ${PKGMESSAGE}
@${ECHO} "environment." >> ${PKGMESSAGE}
@${ECHO} "=====================================================" >> ${PKGMESSAGE}
.endif