aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt-devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-10-26 21:14:24 +0800
committerkrion <krion@FreeBSD.org>2003-10-26 21:14:24 +0800
commit0e6612f6973f99fd1a2a7b6cfafa9a8444fab7ad (patch)
tree550c4e9abca58dbc0f90ebbf0acfbe1437702fdb /mail/mutt-devel
parentc6d0c1bc4d2afed6e0b53da8ffe20d200208cab8 (diff)
downloadfreebsd-ports-gnome-0e6612f6973f99fd1a2a7b6cfafa9a8444fab7ad.tar.gz
freebsd-ports-gnome-0e6612f6973f99fd1a2a7b6cfafa9a8444fab7ad.tar.zst
freebsd-ports-gnome-0e6612f6973f99fd1a2a7b6cfafa9a8444fab7ad.zip
- Fix the DOCSDIR and EXAMPLESDIR code. Now both can be set to
non-standard values. - Be less verbose. PR: 58559 Submitted by: Udo Schweigert <udo.schweigert@siemens.com> (maintainer)
Diffstat (limited to 'mail/mutt-devel')
-rw-r--r--mail/mutt-devel/Makefile22
-rw-r--r--mail/mutt-devel/files/patch-doc-mutt.man20
2 files changed, 33 insertions, 9 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 13f5d4225c8d..0cca9eaa1c83 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -133,7 +133,7 @@ DW_PATCH_VERSION= ${PORTVERSION}
# this should be done automagically by aclocal but ....
# for now, this will have to do
pre-build:
- ${REINPLACE_CMD} -E -e "s|^(ACLOCAL = ).+|\1${ACLOCAL}|" \
+ @${REINPLACE_CMD} -E -e "s|^(ACLOCAL = ).+|\1${ACLOCAL}|" \
-e "s|^(AUTOCONF = ).+|\1${AUTOCONF}|" \
-e "s|^(AUTOMAKE = ).+|\1${AUTOMAKE}|" \
-e "s|^(AUTOHEADER = ).+|\1${AUTOHEADER}|" \
@@ -181,13 +181,13 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
.endif
.if ! defined(WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT)
pre-configure::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-smime-outlook
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-smime-outlook
.endif
.if ! defined(WITHOUT_MUTT_PGP_PATCH)
SGML_NEEDED= yes
pre-configure::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-pgp-dw
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-pgp-dw
.endif
.if defined(WITH_MUTT_LOCALES_FIX)
@@ -243,7 +243,7 @@ MAN5= muttrc.5 mbox.5
post-patch::
@${REINPLACE_CMD} -e 's,/usr/bin/gpg,${LOCALBASE}/bin/gpg,g' \
${WRKSRC}/contrib/gpg.rc
- ${REINPLACE_CMD} -E -e 's|@samplesdir@|${EXAMPLESDIR}|g' \
+ @${REINPLACE_CMD} -E -e 's|@samplesdir@|${EXAMPLESDIR}|g' \
${WRKSRC}/contrib/Makefile.in
pre-configure::
@@ -275,17 +275,21 @@ SCRIPTS_ENV+= MUTT_HTML="yes"
.endif
.if ! defined(WITHOUT_MUTT_QUOTE_PATCH)
post-patch::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-quote
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-quote
.endif
.if !defined(NOPORTDOCS)
SCRIPTS_ENV+= MUTT_PORTDOCS="yes"
post-build:
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-doc-ref
- ${REINPLACE_CMD} -E -e 's|\$$\{PREFIX\}|${PREFIX}|g' \
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-doc-ref
+ @${REINPLACE_CMD} -E -e 's|\$$\{PREFIX\}|${PREFIX}|g' \
-e 's|\$$\{DOCSDIR\}|${DOCSDIR}|g' \
-e 's|\$$\{EXAMPLESDIR\}|${EXAMPLESDIR}|g' \
${WRKSRC}/doc/mutt.man
+ @${REINPLACE_CMD} -E -e 's|\$$\{PREFIX\}|${PREFIX}|g' \
+ -e 's|\$$\{DOCSDIR\}|${DOCSDIR}|g' \
+ -e 's|\$$\{EXAMPLESDIR\}|${EXAMPLESDIR}|g' \
+ ${WRKSRC}/doc/muttrc.man
.if ! defined(WITHOUT_MUTT_HTML)
SGML_USED= yes
.endif
@@ -294,14 +298,14 @@ SGML_USED= yes
.endif
.else # ! NOPORTDOCS
post-patch::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-nodoc-contrib
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-nodoc-contrib
.endif # ! NOPORTDOCS
.if ${SGML_USED} == yes
SCRIPTS_ENV+= MUTT_SGML="yes"
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
post-patch::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-sgmlformat
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-sgmlformat
.endif
pre-install:
diff --git a/mail/mutt-devel/files/patch-doc-mutt.man b/mail/mutt-devel/files/patch-doc-mutt.man
index 82f4a93ffd04..3d6381963abe 100644
--- a/mail/mutt-devel/files/patch-doc-mutt.man
+++ b/mail/mutt-devel/files/patch-doc-mutt.man
@@ -12,3 +12,23 @@
The Mutt manual.
.SH BUGS
.PP
+--- doc/muttrc.man.orig Wed Mar 19 22:55:03 2003
++++ doc/muttrc.man Sun Oct 26 11:16:05 2003
+@@ -1031,7 +1031,7 @@
+ .B dotlock_program
+ .nf
+ Type: path
+-Default: \(lq/usr/local/bin/mutt_dotlock\(rq
++Default: \(lq${PREFIX}/bin/mutt_dotlock\(rq
+ .fi
+ .IP
+ Contains the path of the mutt_dotlock (8) binary to be used by
+@@ -4410,7 +4410,7 @@
+ instead of a raw socket. You may be able to use this to set up
+ preauthenticated connections to your IMAP/POP3 server. Example:
+ .IP
+-tunnel=\(rqssh -q mailhost.net /usr/local/libexec/imapd\(rq
++tunnel=\(rqssh -q mailhost.net ${PREFIX}/libexec/imapd\(rq
+ .IP
+ NOTE: For this example to work you must be able to log in to the remote
+ machine without having to enter a password.
c71bbddeab00dac35e'>GSView is covered by the AFPL license.ale2008-07-211-0/+1 * - Add entry for games/linux-ssamtfemiwi2008-07-201-0/+1 * - Add entry for games/linux-unrealgoldmiwi2008-07-201-0/+1 * - Add entry for games/linux-etqw-demo-servermiwi2008-07-201-1/+2 * - Add games/linux-etqw-serve - Redistribution is limitedmiwi2008-07-201-0/+1 * Update the licensing conditions of Aqua Data Studio.thierry2008-04-201-3/+4 * Add an entry for databases/sqldeveloper.thierry2008-04-061-3/+5 * - csound has been liberatedpav2008-04-041-5/+0 * - Add entry for benchmarks/nttcpjadawin2008-03-311-0/+1 * - Remove duplicate entryjadawin2008-03-191-1/+0 * - Add entry for biology/clustalwjadawin2008-03-191-0/+2 * - Add entry for ventrilo-serverpav2008-03-131-0/+4 * Usual round of cleanups:danfe2008-03-011-160/+203 * 2007-12-12 net-im/wildfire: Use net-im/openfire instead of this portmiwi2008-02-281-2/+0 * 2007-10-31 www/vtiger4: This version is no longer supported by the developersmiwi2008-02-281-1/+0 * Add a note about vpncehaupt2008-02-281-0/+1 * - Add entry for science/dtiquerytabthorpe2008-02-251-0/+1 * Add LEGAL entry for komodo-editarved2008-02-141-0/+1 * - Add an entry for math/rapidtabthorpe2008-02-091-0/+1 * Add en entry for multimedia/vtkmpeg2encode.thierry2008-01-101-0/+3 * - Add RESTRICTED as the license doesn't allow binary redistributionlme2008-01-011-0/+1 * - Add entry for devel/thistest.alepulver2007-12-251-0/+1 * Command Line Interface for the Adaptec SCSI RAID family of RAID controllers,pav2007-12-201-0/+1 * Nero Digital Audio Reference MPEG-4 & 3GPP Audio Encoder.pav2007-12-151-0/+1 * Add netscape navigator and messenger.sat2007-12-151-0/+2 * Remove qmail since license has changed.garga2007-12-121-2/+0 * Add entries about ports/java/linux-sun-jre15 and ports/java/linux-sun-jre16.jkim2007-10-271-0/+4 * Add an entry about ports/textproc/scim-kmfl-sil-ipa-unicode5garga2007-10-251-0/+5 * Remove expired leaf ports:vd2007-10-121-1/+0 * - Add entry about games/linux-nerogameacm2007-10-061-0/+2 * - Add entry for emulators/win4bsd.alepulver2007-10-031-0/+1 * 2007-01-04 print/clibpdf: distfile and homepage disappearedtabthorpe2007-10-011-8/+0 * Remove print/ghostscript-afpl as it has been replaced by print/ghostscript-gplrafan2007-09-241-1/+0 * Add an entry about net-mgmt/send: Not redistributable, license agreement requ...edwin2007-09-231-0/+1 * 2007-08-22 java/jdk11-doc: Obsolete version of jdkmiwi2007-09-191-2/+0 * 2007-09-15 x11-wm/obtuner: broken with recent Openbox and the project is not ...miwi2007-09-181-2/+0 * - Update to 3.0.6miwi2007-09-141-1/+0 * - Add games/linux-savage-samuraiwars entryacm2007-09-101-1/+3 * - Update to 3.7.3trasz2007-09-061-1/+0 * Command-line encoder that outputs aacPlus v2 files (ie. Advanced Audio Coding +pav2007-07-291-0/+1 * - security/metasploit is updated to 3.0rafan2007-07-231-1/+1 * - Add entry for audio/libamrwb (No redistribution allowed).miwi2007-06-071-1/+2 * - Add entry for audio/libamrnb (No redistribution allowed).miwi2007-06-071-0/+1 * Add notes about:miwi2007-06-051-0/+3 * Add dlv to LEGAL, no information about redistributionarved2007-06-021-0/+1 * The port must be downloaded from the WWW and a Serial Number must be purchased.bsam2007-05-261-0/+2 * - Update to latest stable version (is minor than the port version so usealepulver2007-05-031-1/+0 * Redistribution of the VST PlugIns SDK is not allowed.trasz2007-04-151-0/+1 * - Add entry for java/dbvismiwi2007-04-131-0/+1 * - Remove www/urchin5 is marked for removal.miwi2007-04-111-2/+0 * Add a note about sysutils/seatools.bsam2007-04-091-0/+1 * - Remove entry for games/mararhon2-data: merged into games/alephone-data.alepulver2007-03-311-7/+4 * - Add entry for jaca/netbeans5miwi2007-03-201-0/+1 * Add science/gamess as No Redistribution.maho2007-03-131-0/+1 * Add GotoBLAS.maho2007-03-131-0/+1 * Remove expired ports:gabor2007-03-091-4/+0 * - Fix whitespacesmiwi2007-03-091-7/+7 * - Add entry for security/f-protdmiwi2007-03-091-0/+2 * Add www/groupoffice (Free for personal use only)nox2007-02-211-0/+2 * - Add entries for "lang/xds" and "lang/xds-c".alepulver2007-02-171-0/+2 * Remove expired leaf port:vd2007-02-121-2/+0 * - Add entry for graphics/tonicpoint-viewermiwi2007-02-071-0/+1 * Remove kqemu, it is now opensource (GPL version 2)nox2007-02-071-1/+0 * Remove expired leaf port:vd2007-01-251-1/+0 * Add kqemu-kmod, which may not be redistributed.kris2007-01-211-0/+1 * - Remove multimedia/mtv from LEGAL for remove from portstreemiwi2007-01-061-2/+0 * - Remove textproc/nfbtrans from LEGAL for remove from Portstreemiwi2007-01-061-1/+0 * - Add entry for cad/scv.miwi2006-12-221-0/+1 * Clarify restrictions for java/netbeans* (version 5.5 is published under the C...olgeni2006-12-141-1/+2 * Add an entry for jpgraph2.ale2006-12-071-1/+2 * Resurrect emulators/basiliskII and emulators/vmware-tools2 since there arevd2006-12-051-0/+2 * Remove expired ports:vd2006-12-041-3/+0 * - Add entry for sysutils/linux-megaclipav2006-12-011-0/+1 * Remove expired ports:vd2006-11-091-1/+0 * Remove expired leaf ports:vd2006-10-311-2/+0 * Remove ZendOptimizer, since we can distribute distfiles.ale2006-10-101-2/+0 * - Update games/atitd's distfile name.shaun2006-10-101-1/+1 * Add note about multimedia/pvrxxx.alepulver2006-10-061-0/+3 * Sync files masks with the current ports tree.vd2006-10-051-75/+75 * Add a note for security/metasploit-devel.alepulver2006-10-051-0/+1 * Add entry for japanese/citrix_ica.alepulver2006-10-041-0/+1 * - Add note about games/fretsonfire-dataacm2006-10-041-0/+3 * Remove references to nonexistent ports:vd2006-10-031-15/+2 * Remove expired ports:vd2006-10-021-3/+0 * Add a note about comms/hcfmdm.bsam2006-10-021-0/+1 * - Update for devel/uppaalrafan2006-09-171-1/+1 * Remove expired leaf ports:vd2006-09-121-1/+0 * - Add note about games/linux-savageacm2006-09-091-0/+2 * - Add note about sysutils/linux-megamgrbsam2006-09-071-0/+1 * - Merge entry of games/linux-doom3-demo with games/linux-doom3 (recentalepulver2006-09-051-1/+1 * Remove antivir-milterkris2006-09-031-1/+0 * add archivers/lha-acdinoex2006-08-171-0/+1 * - Fix the entry for linux-quake4. Now this affect to linux-quake4 andacm2006-08-031-1/+1 * - Add note about games/linux-quake4acm2006-08-031-0/+1 * - Add note about science/svmlightclsung2006-08-011-0/+3 * - Add note about security/httprintrafan2006-08-011-0/+1 * - Add note about linux-unacesat2006-07-311-0/+2 * - Permission to distribute packages has been grantedsat2006-07-301-2/+1 * - Add autopano-sift:tmclaugh2006-07-301-0/+1 * Add port audio/optimfrog:sat2006-07-221-0/+2 * Add port audio/lpac:sat2006-07-221-0/+1 * Add an entry for games/linux-ut.alepulver2006-06-141-0/+1 * Add an entry in LEGAL for Google Earth.flz2006-06-131-0/+1 * Add a note about security/pam_authsrvgarga2006-06-051-0/+2 * Add entry for audio/linux-shoutcast.itetcu2006-06-051-0/+1 * - Remove games/linux-alienarena (the data is in a separate port).alepulver2006-05-201-1/+0 * Fix file order that I messed up with the last commitjeh2006-05-151-2/+2 * Remove the DAT only port since it is now brough in live in the scanner portjeh2006-05-151-2/+2 * Update security/vscan's file namejeh2006-05-091-1/+1 * Add entry for java/netcomponents.lawrance2006-05-071-0/+2 * * plan9portmnag2006-05-061-3/+0 * - Remove redundant entry for xgobi in wrong positionsem2006-04-301-1/+1 * . Remove the entries for java/diablo-jdk13 and java/diablo-jre13 since theglewis2006-04-251-4/+0 * - Add math/kash3 (no commercial distribution or use)johans2006-04-191-0/+2 * Remove emulators/gngeo because it doesn't package the Neo-Geo BIOS anymorealepulver2006-04-181-2/+0 * Remove www/linux-flashplugin* ports because of license problem.hrs2006-04-081-3/+0 * . Add entries for java/diablo-jdk15 and java/diablo-jre15.glewis2006-04-061-4/+8 * Add net/onion-feclioux2006-04-051-0/+2 * - Fix installation;thierry2006-04-021-0/+1 * Remove expired leaf ports:vd2006-03-311-1/+0 * - Remove polyml.mnag2006-03-291-1/+0 * - Add security/bsd_upektfmesssem2006-03-291-1/+1 * Add audio/shoutcast -- No redistribution allowedgarga2006-03-191-0/+1 * Add x11-themes/gnome-icons-snowishgarga2006-02-231-0/+1 * tw_cli(8) is a Command Line Interface Storage Management Software formnag2006-02-231-0/+2 * Add games/ggohq2006-02-201-0/+1 * Add graphics/linux-adobesvg.jylefort2006-02-181-0/+1 * Add an entry for games/sfbolhq2006-02-141-0/+2 * * Remove print/acroread - it has expired on 2006-01-03vd2006-02-101-3/+0 * - Remove port; project is deadtdb2006-02-071-1/+0 * Add sysutils/freqsdwn.nork2006-02-041-0/+2 * - Add devel/plan9portgarga2006-02-031-0/+3 * Populate newly create net-p2p category with these ports:pav2006-01-311-2/+2 * Mention ``games/aestats'' -- commercial use is prohibited.danfe2006-01-271-0/+1 * - dusage is a peacewarepav2006-01-241-0/+1 * Add japanese/xgate.nork2006-01-161-0/+1 * Add information about devel/simianedwin2005-12-291-0/+2 * Add games/flightgear-mb339-pan.jylefort2005-12-121-0/+1 * Add xxe, whose license says it can't be redistributed.fenner2005-12-101-0/+2 * Add games/linux-x-plane-net-installer.jylefort2005-12-071-0/+1 * Add entry for ports/chinese/dfsongsdbarner2005-12-011-0/+2 * Add information about finance/pfproedwin2005-12-011-0/+3 * Add games/linux-goodway.jylefort2005-11-271-0/+1 * Add games/linux-x-plane.jylefort2005-11-271-0/+1 * add lang/twelfedwin2005-11-261-0/+2 * [NEW PORT] games/gngeo - NeoGeo emulatoredwin2005-11-231-0/+2 * Add games/linux-warsow.jylefort2005-11-231-0/+2 * Add games/linux-alienarena.jylefort2005-11-231-0/+1 * Correct entries for a number of ports that were moved or deleted.lawrance2005-11-191-21/+11 * - Delete due to being unfetchable and being obsoleted by gnome-art portpav2005-11-181-6/+4 * Add entry for devel/uppaalvs2005-11-161-0/+2 * Remove trailing spaces.krion2005-11-131-2/+2 * Re-alphabetize.linimon2005-10-301-2/+2 * Remove a non-sensical line.tobez2005-10-291-1/+0 * Modify pattern for misc/gopod to also match misc/gtk-gopodehaupt2005-10-261-1/+1 * - Add info for graphics/uDrawGraphehaupt2005-10-111-0/+2 * - Add info for games/annelidgarga2005-10-041-0/+1