aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt-devel
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2010-05-06 05:27:19 +0800
committerwxs <wxs@FreeBSD.org>2010-05-06 05:27:19 +0800
commit9e51c3f8b684f8da1fc52ae0b8e782ffe538e861 (patch)
tree1b24aa927167eacfb4872ffde58008afe5811c71 /mail/mutt-devel
parentf84028328bca3e9b445fa7dddcbcefd7a737ec1b (diff)
downloadfreebsd-ports-gnome-9e51c3f8b684f8da1fc52ae0b8e782ffe538e861.tar.gz
freebsd-ports-gnome-9e51c3f8b684f8da1fc52ae0b8e782ffe538e861.tar.zst
freebsd-ports-gnome-9e51c3f8b684f8da1fc52ae0b8e782ffe538e861.zip
Fix build with latest OpenSSL.
PR: ports/146261 Submitted by: Udo Schweigert <udo.schweigert@siemens.com> (maintainer)
Diffstat (limited to 'mail/mutt-devel')
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/mutt-devel/files/patch-mutt-ssl.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 33d5e6ede823..2dde4cb87b5a 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -118,7 +118,7 @@
PORTNAME= mutt-devel
PORTVERSION= 1.5.20
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES+= mail ipv6
.if defined(WITH_MUTT_NNTP)
CATEGORIES+= news
diff --git a/mail/mutt-devel/files/patch-mutt-ssl.c b/mail/mutt-devel/files/patch-mutt-ssl.c
new file mode 100644
index 000000000000..2b021a08d8e4
--- /dev/null
+++ b/mail/mutt-devel/files/patch-mutt-ssl.c
@@ -0,0 +1,11 @@
+--- mutt_ssl.c.orig 2009-06-10 07:08:29.000000000 +0200
++++ mutt_ssl.c 2010-05-03 10:45:21.000000000 +0200
+@@ -652,7 +652,7 @@
+ char *buf = NULL;
+ int bufsize;
+ /* needed to get the DNS subjectAltNames: */
+- STACK *subj_alt_names;
++ STACK_OF(GENERAL_NAME) *subj_alt_names;
+ int subj_alt_names_count;
+ GENERAL_NAME *subj_alt_name;
+ /* did we find a name matching hostname? */