aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt-devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-07-04 19:11:53 +0800
committerkrion <krion@FreeBSD.org>2004-07-04 19:11:53 +0800
commita1f1ffa73ca5e84d30d979b9bec3c88f4f872e80 (patch)
tree37a2cac27aeedf4c1531e39c7f8b58682b725981 /mail/mutt-devel
parent4997e741002defe56545816de5b9ef2dedd44812 (diff)
downloadfreebsd-ports-gnome-a1f1ffa73ca5e84d30d979b9bec3c88f4f872e80.tar.gz
freebsd-ports-gnome-a1f1ffa73ca5e84d30d979b9bec3c88f4f872e80.tar.zst
freebsd-ports-gnome-a1f1ffa73ca5e84d30d979b9bec3c88f4f872e80.zip
Fix "source" command when reading in from a program's stdout
(i.e. the source command's filename ends with a pipe-symbol "|") PR: ports/68650 Submitted by: maintainer Obtained from: mutt's CVS
Diffstat (limited to 'mail/mutt-devel')
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/mutt-devel/files/patch-init.c21
2 files changed, 22 insertions, 1 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 4aacbf7da547..f9fd2caaf4b5 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -84,7 +84,7 @@
PORTNAME= mutt-devel
PORTVERSION= 1.5.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES+= mail ipv6
.if defined(WITH_MUTT_NNTP)
CATEGORIES+= news
diff --git a/mail/mutt-devel/files/patch-init.c b/mail/mutt-devel/files/patch-init.c
index 389b682cfa11..36b72f17d579 100644
--- a/mail/mutt-devel/files/patch-init.c
+++ b/mail/mutt-devel/files/patch-init.c
@@ -37,3 +37,24 @@
#ifndef DOMAIN
#define DOMAIN buffer
+--- init.c.orig
++++ init.c
+@@ -1371,17 +1371,6 @@
+ pid_t pid;
+ struct stat s;
+
+- if (stat (rcfile, &s) < 0)
+- {
+- snprintf (err->data, err->dsize, _("%s: stat: %s"), rcfile, strerror (errno));
+- return (-1);
+- }
+- if (!S_ISREG (s.st_mode))
+- {
+- snprintf (err->data, err->dsize, _("%s: not a regular file"), rcfile);
+- return (-1);
+- }
+-
+ if ((f = mutt_open_read (rcfile, &pid)) == NULL)
+ {
+ snprintf (err->data, err->dsize, "%s: %s", rcfile, strerror (errno));
+