aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt-ng
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-07-02 02:09:39 +0800
committershaun <shaun@FreeBSD.org>2006-07-02 02:09:39 +0800
commitb3d273e355117d6c9a33eb7e734943eaa381623f (patch)
tree6f425028cccdeae74954fdd868e084cc102c43aa /mail/mutt-ng
parent7cdbf28ea022afc000dc4f0dc4d9e16946c19df9 (diff)
downloadfreebsd-ports-gnome-b3d273e355117d6c9a33eb7e734943eaa381623f.tar.gz
freebsd-ports-gnome-b3d273e355117d6c9a33eb7e734943eaa381623f.tar.zst
freebsd-ports-gnome-b3d273e355117d6c9a33eb7e734943eaa381623f.zip
- Update to latest CVS snapshot (identical to previous one)
- Add fix for recent IMAP buffer overflow vulnerability. Approved by: ahze (mentor) Security: VuXML d2a43243-087b-11db-bc36-0008743bf21a
Diffstat (limited to 'mail/mutt-ng')
-rw-r--r--mail/mutt-ng/Makefile2
-rw-r--r--mail/mutt-ng/distinfo6
-rw-r--r--mail/mutt-ng/files/patch-imap_browse.c26
3 files changed, 30 insertions, 4 deletions
diff --git a/mail/mutt-ng/Makefile b/mail/mutt-ng/Makefile
index 9bce36578b9c..0926f760329d 100644
--- a/mail/mutt-ng/Makefile
+++ b/mail/mutt-ng/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mutt-ng
-PORTVERSION= 20060501
+PORTVERSION= 20060630
CATEGORIES= mail
MASTER_SITES= http://nion.modprobe.de/mutt-ng/snapshots/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
diff --git a/mail/mutt-ng/distinfo b/mail/mutt-ng/distinfo
index 5f6d52055b74..93ff0e5f1eb8 100644
--- a/mail/mutt-ng/distinfo
+++ b/mail/mutt-ng/distinfo
@@ -1,3 +1,3 @@
-MD5 (muttng-20060501.tar.gz) = 8b6752e9aebfd8ea78ea99036c760af2
-SHA256 (muttng-20060501.tar.gz) = 0499233085745ecd29a889ff235f7d57ab8c75644ab12efc04e7d4ff101752be
-SIZE (muttng-20060501.tar.gz) = 2734082
+MD5 (muttng-20060630.tar.gz) = ab22e207035bccd2d993d70485756934
+SHA256 (muttng-20060630.tar.gz) = b69d1342ac34509ba5689c15e2426722adb0f5bb52f5e2e8a0d62a67d6b92f03
+SIZE (muttng-20060630.tar.gz) = 2734087
diff --git a/mail/mutt-ng/files/patch-imap_browse.c b/mail/mutt-ng/files/patch-imap_browse.c
new file mode 100644
index 000000000000..dd3eeb9f3e56
--- /dev/null
+++ b/mail/mutt-ng/files/patch-imap_browse.c
@@ -0,0 +1,26 @@
+--- imap/browse.c.orig Thu Aug 11 13:13:13 2005
++++ imap/browse.c Sat Jul 1 16:30:28 2006
+@@ -481,7 +481,7 @@
+
+ if (*s == '\"') {
+ s++;
+- while (*s && *s != '\"') {
++ while (*s && *s != '\"' && n < sizeof (ns) - 1) {
+ if (*s == '\\')
+ s++;
+ ns[n++] = *s;
+@@ -491,11 +491,13 @@
+ s++;
+ }
+ else
+- while (*s && !ISSPACE (*s)) {
++ while (*s && !ISSPACE (*s) && n < sizeof (ns) - 1) {
+ ns[n++] = *s;
+ s++;
+ }
+ ns[n] = '\0';
++ if (n == sizeof (ns) - 1)
++ debug_print (1, ("browse_get_namespace: too long: [%s]\n", ns));
+ /* delim? */
+ s = imap_next_word (s);
+ /* delimiter is meaningless if namespace is "". Why does