aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-04-11 16:34:17 +0800
committerbapt <bapt@FreeBSD.org>2011-04-11 16:34:17 +0800
commit7c2279c9ea2445795906f17a17b4992ef5db8fe5 (patch)
treefa82e80371d6b2ded726b8ca4e53e49b52901507 /mail/mutt
parent00a8191fa754e9677dd68c7595adb287b76a451e (diff)
downloadfreebsd-ports-gnome-7c2279c9ea2445795906f17a17b4992ef5db8fe5.tar.gz
freebsd-ports-gnome-7c2279c9ea2445795906f17a17b4992ef5db8fe5.tar.zst
freebsd-ports-gnome-7c2279c9ea2445795906f17a17b4992ef5db8fe5.zip
Add a new macro to deal with conflict between ncurses from base and ncurses from ports.
If a ports is linked against ncurses from base or from the ports, it should then add: USE_NCURSES=yes it is also possible to specify the hard dependency on the ports ncurses or one the base one adding the following macros: WITH_NCURSES_PORT=yes or WITH_NCURSES_BASE=yes PR: ports/155269 Submitted by: me Reviwed by: pav@ Approved by: portmgr (pav@) Exp-run by: portmgr (pav@)
Diffstat (limited to 'mail/mutt')
-rw-r--r--mail/mutt/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index d3c5fd63be4d..0fd835f19459 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -52,6 +52,8 @@ BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell \
urlview:${PORTSDIR}/textproc/urlview
USE_GMAKE= yes
+USE_NCURSES= yes
+
.endif
.if defined (MUTT_LITE)
PKGNAMESUFFIX= -lite
@@ -75,7 +77,7 @@ USE_ICONV= yes
.if defined(WITH_SLANG)
LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
.elif defined(WITH_NCURSES)
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+WITH_NCURSES_PORT= yes
.endif
.if !defined (MUTT_LITE)
.if defined(WITH_MUTT_CYRUS_SASL)
@@ -126,8 +128,8 @@ CONFIGURE_ARGS+= --with-libiconv-prefix=${PREFIX}
.if defined(WITH_SLANG)
CONFIGURE_ARGS+= --with-slang=${PREFIX}
.elif defined(WITH_NCURSES)
-CONFIGURE_ARGS+= --with-curses=${PREFIX}
-CFLAGS+= -I${PREFIX}/include/ncurses -I${PREFIX}/include
+CONFIGURE_ARGS+= --with-curses=${NCURSESBASE}
+CFLAGS+= -I${NCURSESINC}
.endif
.if !defined(WITHOUT_GSSAPI)
.if exists(${LOCALBASE}/bin/gss-client)