aboutsummaryrefslogtreecommitdiffstats
path: root/mail/nmh/Makefile
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2002-04-22 00:25:02 +0800
committercy <cy@FreeBSD.org>2002-04-22 00:25:02 +0800
commite3ed8a9609aae7da84da724f9e2b430ed38b326c (patch)
tree1aecf8a68749aa38f971e7ee8b1e16a8e620e08c /mail/nmh/Makefile
parent20edc55faac5cdc0f0e304e73368df186fab5d18 (diff)
downloadfreebsd-ports-gnome-e3ed8a9609aae7da84da724f9e2b430ed38b326c.tar.gz
freebsd-ports-gnome-e3ed8a9609aae7da84da724f9e2b430ed38b326c.tar.zst
freebsd-ports-gnome-e3ed8a9609aae7da84da724f9e2b430ed38b326c.zip
Fix the following:
* Alphabetize the comments on the Makefile variables that affect the configure process. * Add a new NMH_EXTRA_CONFIGURE_ARGS var to let builder pass extra args through to configure. * Add a new NMH_POP var to allow builder to disable the --enable-pop configure setting. * Take 'uname' out of the AC_CHECK_FUNCS so the configure script never sets HAVE_UNAME, so that it only uses gethostname(3) to get the hostname. The HAVE_UNAME #define is only used in zotnet/mts/mts.c and it uses gethostname(3) in its stead both times. PR: 36307 Submitted by: MAINTAINER: Scott Blachowicz <Scott.Blachowicz@seaslug.org>
Diffstat (limited to 'mail/nmh/Makefile')
-rw-r--r--mail/nmh/Makefile58
1 files changed, 36 insertions, 22 deletions
diff --git a/mail/nmh/Makefile b/mail/nmh/Makefile
index c1dbe7b4fe54..312f28220dd2 100644
--- a/mail/nmh/Makefile
+++ b/mail/nmh/Makefile
@@ -6,6 +6,25 @@
#
# Makefile variables of interest:
#
+# NMH_EDITOR - pass an EDITOR specification through to nmh's configure
+# script's '--with-editor' option.
+#
+# NMH_EXTRA_CONFIGURE_ARGS - extra args passed through to 'configure'.
+#
+# NMH_LOCKING - specify the style of locking to be used by nmh for the
+# users' spool files (e.g. the 'inc' command). Must match the
+# locking style used by your MTA - the default is FLOCK_LOCKING
+# (the documented behavior for the 'mail.local' delivery program).
+# Do a 'make patch', then look in the source directory (currently
+# the config.h.in file) for more information on different locking
+# settings. Current valid settings are:
+# DOT_LOCKING FCNTL_LOCKING LOCKF_LOCKING FLOCK_LOCKING
+#
+# NMH_MASQUERADE - specify the type(s) of masquerading to allow. This
+# is passed through to nmh's "--enable-masquerade" configure
+# option and the current syntax for that string is:
+# 'draft_from[ mmailid[ username_extension]]'
+#
# NMH_MTS - pass an MTS specification through to nmh's configure
# script's "--with-mts" option. Do a "make extract" and check
# the NMH distribution's "INSTALL" file for more info.
@@ -21,25 +40,11 @@
# rewriting facilities of "qmail-inject", if you are using qmail,
# may be available this way, but not via NMH_MTS=smtp.
#
-# NMH_EDITOR - pass an EDITOR specification through to nmh's configure
-# script's '--with-editor' option.
-#
# NMH_PAGER - pass an PAGER specification through to nmh's configure
# script's '--with-pager' option.
#
-# NMH_LOCKING - specify the style of locking to be used by nmh for the
-# users' spool files (e.g. the 'inc' command). Must match the
-# locking style used by your MTA - the default is FLOCK_LOCKING
-# (the documented behavior for the 'mail.local' delivery program).
-# Do a 'make patch', then look in the source directory (currently
-# the config.h.in file) for more information on different locking
-# settings. Current valid settings are:
-# DOT_LOCKING FCNTL_LOCKING LOCKF_LOCKING FLOCK_LOCKING
-#
-# NMH_MASQUERADE - specify the type(s) of masquerading to allow. This
-# is passed through to nmh's "--enable-masquerade" configure
-# option and the current syntax for that string is:
-# 'draft_from[ mmailid[ username_extension]]'
+# NMH_POP - specify "enable" or "disable" for --enable-pop (or --disable-pop).
+# Default is "enable".
#
# NMH_SMTPSERVERS - specify a blank-separated list of SMTP servers -
# passed through to nmh's configure scripts '--with-smtpservers'
@@ -58,26 +63,35 @@ MAINTAINER= Scott.Blachowicz@seaslug.org
USE_AUTOCONF_VER=213
CONFIGURE_ARGS= --libdir=${PREFIX}/libexec/nmh \
- --sysconfdir=${PREFIX}/etc/nmh --enable-nmh-pop
-.ifdef NMH_MTS
-CONFIGURE_ARGS+= --with-mts=${NMH_MTS}
-.endif
+ --sysconfdir=${PREFIX}/etc/nmh
.ifdef NMH_EDITOR
CONFIGURE_ARGS+= --with-editor=${NMH_EDITOR}
.endif
.ifdef NMH_MASQUERADE
CONFIGURE_ARGS+= --enable-masquerade="${NMH_MASQUERADE}"
.endif
+.ifndef NMH_LOCKING
+NMH_LOCKING=FLOCK_LOCKING
+.endif
+.ifdef NMH_MTS
+CONFIGURE_ARGS+= --with-mts=${NMH_MTS}
+.endif
.ifdef NMH_PAGER
CONFIGURE_ARGS+= --with-pager=${NMH_PAGER}
.endif
+.ifdef NMH_POP
+CONFIGURE_ARGS+= --${NMH_POP}-pop
+.else
+CONFIGURE_ARGS+= --enable-pop
+.endif
.ifdef NMH_SMTPSERVERS
CONFIGURE_ARGS+= --with-smtpservers="${NMH_SMTPSERVERS}"
.endif
-.ifndef NMH_LOCKING
-NMH_LOCKING=FLOCK_LOCKING
+.ifdef NMH_EXTRA_CONFIGURE_ARGS
+CONFIGURE_ARGS+= ${NMH_EXTRA_CONFIGURE_ARGS}
.endif
+
CFLAGS+= -D${NMH_LOCKING}
MAN1= ali.1 anno.1 burst.1 comp.1 dist.1 flist.1 folder.1 forw.1 \