aboutsummaryrefslogtreecommitdiffstats
path: root/mail/nmh/files
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>2001-06-27 22:41:55 +0800
committermarkm <markm@FreeBSD.org>2001-06-27 22:41:55 +0800
commit91c125507dc5905ca98441998a3a2ec8b239b2e9 (patch)
treea841b071351540c4ff8342c2ce8b9d23ff992c65 /mail/nmh/files
parentc4eab6363dc7da1c28308cd80d05739545886fb1 (diff)
downloadfreebsd-ports-gnome-91c125507dc5905ca98441998a3a2ec8b239b2e9.tar.gz
freebsd-ports-gnome-91c125507dc5905ca98441998a3a2ec8b239b2e9.tar.zst
freebsd-ports-gnome-91c125507dc5905ca98441998a3a2ec8b239b2e9.zip
Do not spam installed config files - instead install the config files
with '.default' suffixes.
Diffstat (limited to 'mail/nmh/files')
-rw-r--r--mail/nmh/files/patch-ab35
1 files changed, 30 insertions, 5 deletions
diff --git a/mail/nmh/files/patch-ab b/mail/nmh/files/patch-ab
index 04e24b12f04a..3f54feabd3af 100644
--- a/mail/nmh/files/patch-ab
+++ b/mail/nmh/files/patch-ab
@@ -1,4 +1,4 @@
-diff -ur ../../nmh-1.0.2-DIST/Makefile.in ./Makefile.in
+diff -ur ../../nmh-1.0.4-DIST/Makefile.in ./Makefile.in
--- ../../nmh-1.0.2-DIST/Makefile.in Sun Sep 26 12:43:15 1999
+++ ./Makefile.in Sat Dec 11 11:54:28 1999
@@ -65,6 +65,7 @@
@@ -10,9 +10,9 @@ diff -ur ../../nmh-1.0.2-DIST/Makefile.in ./Makefile.in
.SUFFIXES:
diff -ur ../../../nmh-1.0.3-DIST/etc/Makefile.in ./etc/Makefile.in
---- ../../../nmh-1.0.3-DIST/etc/Makefile.in Thu Jan 6 13:30:07 2000
-+++ ./etc/Makefile.in Mon Feb 28 10:20:34 2000
-@@ -20,6 +20,7 @@
+--- ../../../etc/Makefile.in.orig Tue Mar 14 22:40:47 2000
++++ ./etc/Makefile.in Tue Jun 19 13:47:33 2001
+@@ -22,6 +22,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -20,7 +20,24 @@ diff -ur ../../../nmh-1.0.3-DIST/etc/Makefile.in ./etc/Makefile.in
INSTALL_DATA = @INSTALL_DATA@
# Path to search for programs to handle MIME
-@@ -89,7 +90,7 @@
+@@ -78,29 +79,23 @@
+ install-files:
+ $(top_srcdir)/mkinstalldirs $(etcdir)
+ for file in $(DIST_FILES); do \
+- if [ -f $(etcdir)/$$file ]; then \
+- mv $(etcdir)/$$file $(etcdir)/$$file.old; \
+- fi; \
+- $(INSTALL_DATA) $(srcdir)/$$file $(etcdir)/$$file; \
++ $(INSTALL_DATA) $(srcdir)/$$file $(etcdir)/$$file.default; \
+ done
+ for file in $(GEN_FILES); do \
+- if [ -f $(etcdir)/$$file ]; then \
+- mv $(etcdir)/$$file $(etcdir)/$$file.old; \
+- fi; \
+- $(INSTALL_DATA) $$file $(etcdir)/$$file; \
++ $(INSTALL_DATA) $$file $(etcdir)/$$file.default; \
+ done
+
install-scripts:
$(top_srcdir)/mkinstalldirs $(bindir)
for script in $(SCRIPTS); do \
@@ -29,3 +46,11 @@ diff -ur ../../../nmh-1.0.3-DIST/etc/Makefile.in ./etc/Makefile.in
done
uninstall: uninstall-files uninstall-scripts
+
+ uninstall-files:
+ for file in $(FILES); do \
+- rm -f $(etcdir)/$$file; \
++ rm -f $(etcdir)/$$file.default; \
+ done
+
+ uninstall-scripts: