aboutsummaryrefslogtreecommitdiffstats
path: root/mail/nmzmail/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-07-26 04:03:32 +0800
committersem <sem@FreeBSD.org>2005-07-26 04:03:32 +0800
commit5968be46841d16ee81f244886d2ecc83f731ad00 (patch)
treeb090a8554dd7e93827e9d8a29b9f97e699bd33f7 /mail/nmzmail/Makefile
parent4eb61265bbd7b9efae7aea36029370f98f7a89b3 (diff)
downloadfreebsd-ports-gnome-5968be46841d16ee81f244886d2ecc83f731ad00.tar.gz
freebsd-ports-gnome-5968be46841d16ee81f244886d2ecc83f731ad00.tar.zst
freebsd-ports-gnome-5968be46841d16ee81f244886d2ecc83f731ad00.zip
- Update to 0.1.3
PR: ports/84086 Submitted by: Andrej Zverev <az@inec.ru> Approved by: maintainer
Diffstat (limited to 'mail/nmzmail/Makefile')
-rw-r--r--mail/nmzmail/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/mail/nmzmail/Makefile b/mail/nmzmail/Makefile
index c0bf2350083b..d8a3a815131b 100644
--- a/mail/nmzmail/Makefile
+++ b/mail/nmzmail/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= nmzmail
-PORTVERSION= 0.1.2
+PORTVERSION= 0.1.3
CATEGORIES= mail
MASTER_SITES= http://www.ecademix.com/JohannesHofmann/
@@ -17,10 +17,12 @@ COMMENT= Fast mail searching for mutt
RUN_DEPENDS= namazu:${PORTSDIR}/databases/namazu2 \
mutt:${PORTSDIR}/mail/mutt
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-ALL_TARGET= # empty
+
PLIST_FILES= bin/nmzmail
-PORTDOCS= README
+PORTDOCS= README NEWS
.include <bsd.port.pre.mk>
@@ -28,13 +30,12 @@ PORTDOCS= README
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nmzmail ${PREFIX}/bin
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+ for f in ${PORTDOCS}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
+ done
.endif
.include <bsd.port.post.mk>