aboutsummaryrefslogtreecommitdiffstats
path: root/mail/notmuch
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-08-19 21:51:11 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-08-19 21:51:11 +0800
commit593cb02f178ca5c53a8752c8fb0c1a4b2115fce4 (patch)
treee21b7d3944228b1cbbcddbc5e6bd4ba2a3fabe08 /mail/notmuch
parent1b8d157763afbef2c8f8c6954c93791945260f8d (diff)
downloadfreebsd-ports-gnome-593cb02f178ca5c53a8752c8fb0c1a4b2115fce4.tar.gz
freebsd-ports-gnome-593cb02f178ca5c53a8752c8fb0c1a4b2115fce4.tar.zst
freebsd-ports-gnome-593cb02f178ca5c53a8752c8fb0c1a4b2115fce4.zip
- Update from 0.22 to 0.22.1
- New MANPAGES and DOXYGEN options to control building of documentation (DOXYGEN option is used to build API manpage) - RUBY option to support ruby bindings - General port cleanup - While here, add LICENSE_FILE PR: 211266 Submitted by: mp39590@gmail.com (maintainer)
Diffstat (limited to 'mail/notmuch')
-rw-r--r--mail/notmuch/Makefile27
-rw-r--r--mail/notmuch/distinfo6
-rw-r--r--mail/notmuch/pkg-plist35
3 files changed, 36 insertions, 32 deletions
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index 2e5e602fceec..8fdfe97d7591 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= notmuch
-PORTVERSION= 0.22
+PORTVERSION= 0.22.1
CATEGORIES= mail
MASTER_SITES= http://notmuchmail.org/releases/
@@ -10,32 +10,35 @@ MAINTAINER= mp39590@gmail.com
COMMENT= Thread-based email index, search, and tagging application
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING-GPL-3
-BROKEN_powerpc64= Does not build
-
-BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
- c++filt:devel/binutils
+BUILD_DEPENDS= c++filt:devel/binutils
LIB_DEPENDS= libgmime-2.6.so:mail/gmime26 \
libxapian.so:databases/xapian-core \
libtalloc.so:devel/talloc
-OPTIONS_DEFINE= BASH EMACS ZSH
-BASH_DESC= Install bash completion (requires shells/bash-completion)
+BROKEN_powerpc64= Does not build
+
+OPTIONS_DEFINE= BASH DOXYGEN EMACS MANPAGES RUBY ZSH
EMACS_DESC= Install EMACS lisp files (requires emacs)
-ZSH_DESC= Install zsh completion
OPTIONS_SUB= yes
BASH_BUILD_DEPENDS= bash-completion>=1.90:shells/bash-completion
BASH_RUN_DEPENDS= ${BASH_BUILD_DEPENDS}
-BASH_CONFIGURE_OFF= --without-bash-completion
-EMACS_CONFIGURE_OFF= --without-emacs
+BASH_CONFIGURE_WITH= bash-completion
+DOXYGEN_CONFIGURE_WITH= api-docs
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+EMACS_CONFIGURE_WITH= emacs
EMACS_CONFIGURE_ON= --emacslispdir=${PREFIX}/${EMACS_SITE_LISPDIR} \
--emacsetcdir=${PREFIX}/${EMACS_SITE_LISPDIR}
-EMACS_USE= EMACS=yes
-ZSH_CONFIGURE_OFF= --without-zsh-completion
+EMACS_USE= EMACS=yes
+MANPAGES_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
+RUBY_USE= RUBY=yes
+ZSH_CONFIGURE_WITH= zsh-completion
HAS_CONFIGURE= yes
USES= gmake pkgconfig python:build
+USE_GNOME= glib20
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
USE_LDCONFIG= yes
diff --git a/mail/notmuch/distinfo b/mail/notmuch/distinfo
index 28d53c16c631..21bcf8098dcf 100644
--- a/mail/notmuch/distinfo
+++ b/mail/notmuch/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463745210
-SHA256 (notmuch-0.22.tar.gz) = d64118ef926ba06fba814a89a75d20b0c8c8ec07dd65e41bb9f1e9db0dcfb99a
-SIZE (notmuch-0.22.tar.gz) = 682458
+TIMESTAMP = 1469017581
+SHA256 (notmuch-0.22.1.tar.gz) = e739457794f3c2b363beffa3ed9e8a2786921031c80672f5b06d0880876a974b
+SIZE (notmuch-0.22.1.tar.gz) = 683286
diff --git a/mail/notmuch/pkg-plist b/mail/notmuch/pkg-plist
index b9580cc124ea..52d91041e088 100644
--- a/mail/notmuch/pkg-plist
+++ b/mail/notmuch/pkg-plist
@@ -3,23 +3,24 @@ include/notmuch.h
lib/libnotmuch.so
lib/libnotmuch.so.4
lib/libnotmuch.so.4.3.0
-man/man1/notmuch-address.1.gz
-man/man1/notmuch-compact.1.gz
-man/man1/notmuch-config.1.gz
-man/man1/notmuch-count.1.gz
-man/man1/notmuch-dump.1.gz
-man/man1/notmuch-emacs-mua.1.gz
-man/man1/notmuch-insert.1.gz
-man/man1/notmuch-new.1.gz
-man/man1/notmuch-reply.1.gz
-man/man1/notmuch-restore.1.gz
-man/man1/notmuch-search.1.gz
-man/man1/notmuch-setup.1.gz
-man/man1/notmuch-show.1.gz
-man/man1/notmuch-tag.1.gz
-man/man1/notmuch.1.gz
-man/man5/notmuch-hooks.5.gz
-man/man7/notmuch-search-terms.7.gz
+%%MANPAGES%%man/man1/notmuch-address.1.gz
+%%MANPAGES%%man/man1/notmuch-compact.1.gz
+%%MANPAGES%%man/man1/notmuch-config.1.gz
+%%MANPAGES%%man/man1/notmuch-count.1.gz
+%%MANPAGES%%man/man1/notmuch-dump.1.gz
+%%MANPAGES%%man/man1/notmuch-emacs-mua.1.gz
+%%MANPAGES%%man/man1/notmuch-insert.1.gz
+%%MANPAGES%%man/man1/notmuch-new.1.gz
+%%MANPAGES%%man/man1/notmuch-reply.1.gz
+%%MANPAGES%%man/man1/notmuch-restore.1.gz
+%%MANPAGES%%man/man1/notmuch-search.1.gz
+%%MANPAGES%%man/man1/notmuch-setup.1.gz
+%%MANPAGES%%man/man1/notmuch-show.1.gz
+%%MANPAGES%%man/man1/notmuch-tag.1.gz
+%%MANPAGES%%man/man1/notmuch.1.gz
+%%DOXYGEN%%man/man3/notmuch.3.gz
+%%MANPAGES%%man/man5/notmuch-hooks.5.gz
+%%MANPAGES%%man/man7/notmuch-search-terms.7.gz
%%BASH%%etc/bash_completion.d/notmuch
%%EMACS%%share/emacs/site-lisp/coolj.el
%%EMACS%%share/emacs/site-lisp/coolj.elc