aboutsummaryrefslogtreecommitdiffstats
path: root/mail/opensmtpd-extras-table-passwd
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-04-16 09:37:52 +0800
committeradamw <adamw@FreeBSD.org>2016-04-16 09:37:52 +0800
commit2a418031d671d6525147acc48146525f21f733b5 (patch)
treebd2d355c19d906910c23398176518f603e15153a /mail/opensmtpd-extras-table-passwd
parent8d149734798bcc6dbc23a0a077e7942a10a03323 (diff)
downloadfreebsd-ports-gnome-2a418031d671d6525147acc48146525f21f733b5.tar.gz
freebsd-ports-gnome-2a418031d671d6525147acc48146525f21f733b5.tar.zst
freebsd-ports-gnome-2a418031d671d6525147acc48146525f21f733b5.zip
Split opensmtpd-extras into a bunch of slave ports. Right now -extras
only has the table stuff, but there are many more pieces. Having the default package install postgresql, redis, and mysql when all you wanted was passwd support, is overkill. Ports for filters will come soon. The -extras port retains its OPTIONS (and still installs everything possible, so there's no disruption for current users). Approved by: gahr (maintainer)
Diffstat (limited to 'mail/opensmtpd-extras-table-passwd')
-rw-r--r--mail/opensmtpd-extras-table-passwd/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/mail/opensmtpd-extras-table-passwd/Makefile b/mail/opensmtpd-extras-table-passwd/Makefile
new file mode 100644
index 000000000000..41afecb6c8b6
--- /dev/null
+++ b/mail/opensmtpd-extras-table-passwd/Makefile
@@ -0,0 +1,17 @@
+# Created by: gahr
+# $FreeBSD$
+
+PKGNAMESUFFIX= -table-passwd
+
+COMMENT= passwd(5) table support for opensmtpd
+
+PLIST_FILES= libexec/opensmtpd/table-passwd \
+ man/man5/table-passwd.5.gz
+
+CONFIGURE_ARGS= --with-table-passwd
+LDFLAGS+= -L${LOCALBASE}/lib/mysql
+
+MASTERDIR= ${.CURDIR}/../opensmtpd-extras
+SLAVE_PORT= yes
+
+.include "${MASTERDIR}/Makefile"