aboutsummaryrefslogtreecommitdiffstats
path: root/mail/opensmtpd
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2015-03-29 13:17:43 +0800
committerashish <ashish@FreeBSD.org>2015-03-29 13:17:43 +0800
commit98a455664ebcc6235206b6bcb4d16f7f7fb0efdf (patch)
tree02d6370f485c59c7d74973ac62f6ee96f6acfead /mail/opensmtpd
parentac16b0112bf2e6dd4a909365b02c0e6d01a61f95 (diff)
downloadfreebsd-ports-gnome-98a455664ebcc6235206b6bcb4d16f7f7fb0efdf.tar.gz
freebsd-ports-gnome-98a455664ebcc6235206b6bcb4d16f7f7fb0efdf.tar.zst
freebsd-ports-gnome-98a455664ebcc6235206b6bcb4d16f7f7fb0efdf.zip
- Add OPTION to only update mailer.conf(5) on demand
- Update COMMENT so it complies with guidelines in Porter's Handbook PR: 198375 Submitted by: adamw
Diffstat (limited to 'mail/opensmtpd')
-rw-r--r--mail/opensmtpd/Makefile6
-rw-r--r--mail/opensmtpd/files/pkg-deinstall.in2
-rw-r--r--mail/opensmtpd/files/pkg-install.in2
3 files changed, 6 insertions, 4 deletions
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index 0eb5ed688510..28f13e0d0030 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -11,18 +11,20 @@ MASTER_SITES= http://www.opensmtpd.org/archives/ \
DISTNAME= ${PORTNAME}-${PORTVERSION}p1
MAINTAINER= ashish@FreeBSD.org
-COMMENT= OpenSMTPD is a free MTA
+COMMENT= Security- and simplicity-focused SMTP server from OpenBSD
LICENSE= ISCL
LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
-OPTIONS_DEFINE= CA_BUNDLE PAM SQLITE MYSQL PGSQL LDAP REDIS LIBASRDEVEL
+OPTIONS_DEFINE= CA_BUNDLE PAM SQLITE MYSQL PGSQL LDAP REDIS LIBASRDEVEL \
+ MAILERCONF
OPTIONS_DEFAULT= CA_BUNDLE PAM
CA_BUNDLE_DESC= Install CA bundle for OpenSSL
LIBASRDEVEL_DESC= Use development version of libasr
+MAILERCONF_DESC= Activate OpenSMTPD in mailer.conf(5)
USES= libtool
USE_OPENSSL= yes
diff --git a/mail/opensmtpd/files/pkg-deinstall.in b/mail/opensmtpd/files/pkg-deinstall.in
index 3c939c99eee1..cdc50001245a 100644
--- a/mail/opensmtpd/files/pkg-deinstall.in
+++ b/mail/opensmtpd/files/pkg-deinstall.in
@@ -5,7 +5,7 @@ TARGET=$2
PREFIX=$(echo %%PREFIX%% |sed -e 's,/,\\/,g')
-if [ "$TARGET" = POST-DEINSTALL ]; then
+if [ "$TARGET" = POST-DEINSTALL -a -z "%%MAILERCONF%%" ]; then
sed -e '/[[:space:]]'$PREFIX'\/sbin\/smtpctl/d' \
-e '/[[:space:]]'$PREFIX'\/libexec\/opensmtpd\/makemap/d' \
-e 's/^### smtpd: //g' -i '' /etc/mail/mailer.conf
diff --git a/mail/opensmtpd/files/pkg-install.in b/mail/opensmtpd/files/pkg-install.in
index 899ad234742e..d86bb26627e9 100644
--- a/mail/opensmtpd/files/pkg-install.in
+++ b/mail/opensmtpd/files/pkg-install.in
@@ -3,7 +3,7 @@
PKGNAME=$1
TARGET=$2
-if [ "$TARGET" = POST-INSTALL ]; then
+if [ "$TARGET" = POST-INSTALL -a -z "%%MAILERCONF%%" ]; then
sed -e '/^[^#]/s/^/### smtpd: /g' -i '' /etc/mail/mailer.conf
cat >>/etc/mail/mailer.conf <<EOF
sendmail %%PREFIX%%/sbin/smtpctl