aboutsummaryrefslogtreecommitdiffstats
path: root/mail/openwebmail
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-05-12 16:47:44 +0800
committerleeym <leeym@FreeBSD.org>2005-05-12 16:47:44 +0800
commitb9da3f81b2b213757decef15309df1de703c04ed (patch)
tree3d99cb56efff5d71c86efbea7a3ba91c24d551d8 /mail/openwebmail
parentbe71275efdf6092ac31a1fda18a7e30832f1eab8 (diff)
downloadfreebsd-ports-gnome-b9da3f81b2b213757decef15309df1de703c04ed.tar.gz
freebsd-ports-gnome-b9da3f81b2b213757decef15309df1de703c04ed.tar.zst
freebsd-ports-gnome-b9da3f81b2b213757decef15309df1de703c04ed.zip
- do initialization tasks in pkg-install instead
Diffstat (limited to 'mail/openwebmail')
-rw-r--r--mail/openwebmail/Makefile1
-rw-r--r--mail/openwebmail/pkg-install3
2 files changed, 3 insertions, 1 deletions
diff --git a/mail/openwebmail/Makefile b/mail/openwebmail/Makefile
index a60abc306228..fdd2eefe6903 100644
--- a/mail/openwebmail/Makefile
+++ b/mail/openwebmail/Makefile
@@ -205,7 +205,6 @@ do-install:
.if defined(WITHOUT_SPEEDYCGI)
@${PERL} ${OWCGIDIR}/misc/tools/wrapsuid/wrapsuid.pl ${OWCGIDIR} 2>/dev/null
.endif
- @${OWCGIDIR}/openwebmail-tool.pl --init --no
post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/mail/openwebmail/pkg-install b/mail/openwebmail/pkg-install
index 53c5ab67c94a..fc74006d6cea 100644
--- a/mail/openwebmail/pkg-install
+++ b/mail/openwebmail/pkg-install
@@ -3,6 +3,9 @@ if [ "$2" != "POST-INSTALL" ]; then
exit 0
fi
+mkdir -p ${PKG_PREFIX}/www/cgi-bin/openwebmail/etc/sessions
chmod 0770 ${PKG_PREFIX}/www/cgi-bin/openwebmail/etc/sessions
+mkdir -p ${PKG_PREFIX}/www/cgi-bin/openwebmail/etc/users
chmod 0700 ${PKG_PREFIX}/www/cgi-bin/openwebmail/etc/users
chmod 4755 ${PKG_PREFIX}/www/cgi-bin/openwebmail/openwebmail*pl
+${PKG_PREFIX}/www/cgi-bin/openwebmail/openwebmail-tool.pl --init --no