aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-Email-Stuff
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-08-27 17:08:40 +0800
committermiwi <miwi@FreeBSD.org>2009-08-27 17:08:40 +0800
commitadd730f87f3ac81af57e9e62b640f28acda1105c (patch)
tree8fb59a1457cb33e1ebc65b49ee76317140870812 /mail/p5-Email-Stuff
parentbcefd2548411f127806ed7a5bbde1a371e036bb0 (diff)
downloadfreebsd-ports-gnome-add730f87f3ac81af57e9e62b640f28acda1105c.tar.gz
freebsd-ports-gnome-add730f87f3ac81af57e9e62b640f28acda1105c.tar.zst
freebsd-ports-gnome-add730f87f3ac81af57e9e62b640f28acda1105c.zip
Email::Stuff, as its name suggests, is a fairly casual module
used to email "stuff" to people using the most common methods. It is a high-level module designed for ease of use when doing a very specific common task, but implemented on top of the tight and correct Email:: modules. Email::Stuff is typically used to build emails and send them in a single statement, as seen in the synopsis. And it is certain only for use when creating and sending emails. As such, it contains no email parsing capability, and little to no modification support. WWW: http://search.cpan.org/dist/Email-Stuff/ PR: ports/138194 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'mail/p5-Email-Stuff')
-rw-r--r--mail/p5-Email-Stuff/Makefile27
-rw-r--r--mail/p5-Email-Stuff/distinfo3
-rw-r--r--mail/p5-Email-Stuff/pkg-descr13
-rw-r--r--mail/p5-Email-Stuff/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/mail/p5-Email-Stuff/Makefile b/mail/p5-Email-Stuff/Makefile
new file mode 100644
index 000000000000..6c23f8453dcc
--- /dev/null
+++ b/mail/p5-Email-Stuff/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Email-Stuff
+# Date created: 12 Aug, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-Stuff
+PORTVERSION= 2.100
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A more casual approach to creating and sending Email
+
+BUILD_DEPENDS= p5-prefork>=1.01:${PORTSDIR}/devel/p5-prefork \
+ p5-Params-Util>=0.23:${PORTSDIR}/devel/p5-Params-Util \
+ p5-File-Type>=0.22:${PORTSDIR}/devel/p5-File-Type \
+ p5-Email-Send>=2.185:${PORTSDIR}/mail/p5-Email-Send
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::Stuff.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-Stuff/distinfo b/mail/p5-Email-Stuff/distinfo
new file mode 100644
index 000000000000..da6ff3e1cf2a
--- /dev/null
+++ b/mail/p5-Email-Stuff/distinfo
@@ -0,0 +1,3 @@
+MD5 (Email-Stuff-2.100.tar.gz) = 692e869873d2168730e528c14353846b
+SHA256 (Email-Stuff-2.100.tar.gz) = 8b148c4d91073fb980c0d48dd17cd66fcd89d7dcf90e5acbb811d9328abb7ca1
+SIZE (Email-Stuff-2.100.tar.gz) = 35677
diff --git a/mail/p5-Email-Stuff/pkg-descr b/mail/p5-Email-Stuff/pkg-descr
new file mode 100644
index 000000000000..e1b96654808d
--- /dev/null
+++ b/mail/p5-Email-Stuff/pkg-descr
@@ -0,0 +1,13 @@
+Email::Stuff, as its name suggests, is a fairly casual module
+used to email "stuff" to people using the most common methods.
+It is a high-level module designed for ease of use when doing
+a very specific common task, but implemented on top of the
+tight and correct Email:: modules.
+
+Email::Stuff is typically used to build emails and send them
+in a single statement, as seen in the synopsis. And it is
+certain only for use when creating and sending emails. As such,
+it contains no email parsing capability, and little to no
+modification support.
+
+WWW: http://search.cpan.org/dist/Email-Stuff/
diff --git a/mail/p5-Email-Stuff/pkg-plist b/mail/p5-Email-Stuff/pkg-plist
new file mode 100644
index 000000000000..3eff68f82b83
--- /dev/null
+++ b/mail/p5-Email-Stuff/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Email/Stuff.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Stuff/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Stuff
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email
+@dirrmtry %%SITE_PERL%%/Email