aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-GMail-IMAPD
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2007-06-07 23:08:09 +0800
committerahze <ahze@FreeBSD.org>2007-06-07 23:08:09 +0800
commit1ddd1070fbf038f6093f71716ccff8855ce25ded (patch)
tree4db7a292b6d456b877ad8988278eca9d75cb1603 /mail/p5-GMail-IMAPD
parent34fc32b1c88ffc6b167b9a75e0337d3bad66302b (diff)
downloadfreebsd-ports-gnome-1ddd1070fbf038f6093f71716ccff8855ce25ded.tar.gz
freebsd-ports-gnome-1ddd1070fbf038f6093f71716ccff8855ce25ded.tar.zst
freebsd-ports-gnome-1ddd1070fbf038f6093f71716ccff8855ce25ded.zip
Add p5-GMail-IMAPD 0.94, perl IMAP4 gateway to Google's webmail service.
PR: ports/113420 Submitted by: Ali Mashtizadeh <ali at mashtizadeh.org>
Diffstat (limited to 'mail/p5-GMail-IMAPD')
-rw-r--r--mail/p5-GMail-IMAPD/Makefile32
-rw-r--r--mail/p5-GMail-IMAPD/pkg-descr9
-rw-r--r--mail/p5-GMail-IMAPD/pkg-plist5
3 files changed, 46 insertions, 0 deletions
diff --git a/mail/p5-GMail-IMAPD/Makefile b/mail/p5-GMail-IMAPD/Makefile
new file mode 100644
index 000000000000..7c68e525cf83
--- /dev/null
+++ b/mail/p5-GMail-IMAPD/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: GMail-IMAPD
+# Date created: Jun 4, 2007
+# Whom: Ali Mashtizadeh <ali@mashtizadeh.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GMail-IMAPD
+PORTVERSION= 0.94
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= GMail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mashtizadeh@gmail.com
+COMMENT= Perl IMAP4 gateway to Google's webmail service
+
+BUILD_DEPENDS= ${SITE_PERL}/Mail/Webmail/Gmail.pm:${PORTSDIR}/mail/p5-Mail-Webmail-Gmail
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= GMail::IMAPD.3
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${PERL_LEVEL} < 500601
+ @${PERL} -pi -e 's/\r//g;s/^our/my/g' ${WRKSRC}/lib/GMail/IMAPD.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-GMail-IMAPD/pkg-descr b/mail/p5-GMail-IMAPD/pkg-descr
new file mode 100644
index 000000000000..f324c842279f
--- /dev/null
+++ b/mail/p5-GMail-IMAPD/pkg-descr
@@ -0,0 +1,9 @@
+This module allows users to access their Gmail messages with an IMAP
+client by running a server which accepts IMAP connections.
+
+Currently this module supports only a subset of the IMAP4 protocol.
+
+WWW: http://search.cpan.org/dist/GMail-IMAPD/
+
+- Ali Mashtizadeh
+ali@mashtizadeh.org
diff --git a/mail/p5-GMail-IMAPD/pkg-plist b/mail/p5-GMail-IMAPD/pkg-plist
new file mode 100644
index 000000000000..c50b460be0bc
--- /dev/null
+++ b/mail/p5-GMail-IMAPD/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/GMail/IMAPD.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GMail/IMAPD/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GMail/IMAPD
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GMail
+@dirrm %%SITE_PERL%%/GMail