aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-IMAP-Admin/Makefile
diff options
context:
space:
mode:
authordan <dan@FreeBSD.org>1999-09-27 13:13:04 +0800
committerdan <dan@FreeBSD.org>1999-09-27 13:13:04 +0800
commit35dc73ef0773f7d35371e27725cf8d6e6eddf773 (patch)
tree94c03a15410e8a6596e9ae40544b3936aa20eab0 /mail/p5-IMAP-Admin/Makefile
parent87ae668c8872e910816fedd87c8805b7b9fd5591 (diff)
downloadfreebsd-ports-gnome-35dc73ef0773f7d35371e27725cf8d6e6eddf773.tar.gz
freebsd-ports-gnome-35dc73ef0773f7d35371e27725cf8d6e6eddf773.tar.zst
freebsd-ports-gnome-35dc73ef0773f7d35371e27725cf8d6e6eddf773.zip
IMAP-Admin is a Perl module for basic IMAP server administration. With
this module it's easy to make Perl scripts to create new and remove obsolete IMAP accounts, set user quotas on Cyrus server etc. PR: ports/13990 Submitted by: Martti Kuparinen <martti.kuparinen@research.zopps.fi>
Diffstat (limited to 'mail/p5-IMAP-Admin/Makefile')
-rw-r--r--mail/p5-IMAP-Admin/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/mail/p5-IMAP-Admin/Makefile b/mail/p5-IMAP-Admin/Makefile
new file mode 100644
index 000000000000..ed5fbc68dd3a
--- /dev/null
+++ b/mail/p5-IMAP-Admin/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-IMAP-Admin
+# Version required: 0.8.2
+# Date created: Sun Sep 26 09:25:38 EEST 1999
+# Whom: Martti Kuparinen <martti.kuparinen@ericsson.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= IMAP-Admin-0.8.2
+PKGNAME= p5-IMAP-Admin-0.8.2
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IMAP
+
+MAINTAINER= martti.kuparinen@ericsson.com
+
+USE_PERL5= YES
+
+MAN3= IMAP::Admin.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/examples/p5-IMAP-Admin
+ @${INSTALL_DATA} ${WRKSRC}/examples/create.pl \
+ ${WRKSRC}/examples/delete.pl \
+ ${PREFIX}/share/examples/p5-IMAP-Admin
+ @${ECHO} ""
+ @${ECHO} "*******************************************************************************"
+ @${ECHO} "See ${PREFIX}/share/examples/p5-IMAP-Admin for some examples..."
+ @${ECHO} "*******************************************************************************"
+ @${ECHO} ""
+
+.include <bsd.port.mk>