aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-Mail-Box/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:35:11 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:35:11 +0800
commitb88d0cc60f0d92e5ad4e101953862288251a9854 (patch)
tree9a08da87036be011d2f11194c22c7b7641592c76 /mail/p5-Mail-Box/Makefile
parent99cfd462822873c81e7c834f12ec4b4e4b4326ba (diff)
downloadfreebsd-ports-gnome-b88d0cc60f0d92e5ad4e101953862288251a9854.tar.gz
freebsd-ports-gnome-b88d0cc60f0d92e5ad4e101953862288251a9854.tar.zst
freebsd-ports-gnome-b88d0cc60f0d92e5ad4e101953862288251a9854.zip
Add p5-Mail-Box 0.4, perl module implementing a modern mail-folder
managerat.
Diffstat (limited to 'mail/p5-Mail-Box/Makefile')
-rw-r--r--mail/p5-Mail-Box/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/mail/p5-Mail-Box/Makefile b/mail/p5-Mail-Box/Makefile
new file mode 100644
index 000000000000..403a7da36e22
--- /dev/null
+++ b/mail/p5-Mail-Box/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Mail-Box
+# Date created: Wed Jan 3 12:54:59 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-Box
+PORTVERSION= 0.4
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/MIME/Entity.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500007
+BROKEN= "Requires Perl 5.6.0 for 'our' keyword"
+.endif
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Mail::Box.3 Mail::Box::Tie.3 Mail::Box::Mbox.3 \
+ Mail::Box::MH.3 Mail::Box::Manager.3 \
+ Mail::Box::Message.3 Mail::Box::Threads.3 \
+ Mail::Box::Locker.3 Mail::Box::Index.3
+
+.include <bsd.port.post.mk>