aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-Mail-Spool/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-10-24 18:14:58 +0800
committersobomax <sobomax@FreeBSD.org>2002-10-24 18:14:58 +0800
commit5ac1eebb94898fd55d318688ed2d2a21431e9b9a (patch)
treee575746ec39b6b5051be902f2141bb2514f286dc /mail/p5-Mail-Spool/Makefile
parente754539ef1643b09e937d89ea30987f83bc48e78 (diff)
downloadfreebsd-ports-gnome-5ac1eebb94898fd55d318688ed2d2a21431e9b9a.tar.gz
freebsd-ports-gnome-5ac1eebb94898fd55d318688ed2d2a21431e9b9a.tar.zst
freebsd-ports-gnome-5ac1eebb94898fd55d318688ed2d2a21431e9b9a.zip
Add p5-Mail-Spool 0.50, a "pure perl" implementation of mail
spooling, unspooling and sending.
Diffstat (limited to 'mail/p5-Mail-Spool/Makefile')
-rw-r--r--mail/p5-Mail-Spool/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/mail/p5-Mail-Spool/Makefile b/mail/p5-Mail-Spool/Makefile
new file mode 100644
index 000000000000..06a94b4e56ec
--- /dev/null
+++ b/mail/p5-Mail-Spool/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Mail::Spool
+# Date created: 24 October 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-Spool
+PORTVERSION= 0.50
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/File/NFSLock.pm:${PORTSDIR}/devel/p5-File-NFSLock \
+ ${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
+ ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Mail::Spool.3 Mail::Spool::Handle.3 Mail::Spool::Node.3
+
+.include <bsd.port.mk>