aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-Net-SMTP-SSL
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-06-23 06:45:10 +0800
committerwxs <wxs@FreeBSD.org>2008-06-23 06:45:10 +0800
commitf78b220e7c09f39bd226a88f652e68be08f22bad (patch)
tree2876e5d4f2f4bcfa5c0d3a9a3b3cd692c24a84d9 /mail/p5-Net-SMTP-SSL
parent5a773a39b9696c5b980fbc04180a62fbeb529316 (diff)
downloadfreebsd-ports-gnome-f78b220e7c09f39bd226a88f652e68be08f22bad.tar.gz
freebsd-ports-gnome-f78b220e7c09f39bd226a88f652e68be08f22bad.tar.zst
freebsd-ports-gnome-f78b220e7c09f39bd226a88f652e68be08f22bad.zip
New port: p5-Net-SMTP-SSL
Implements the same API as Net::SMTP, but uses IO::Socket::SSL for its network operations. Due to the nature of Net::SMTP's new method, it is not overridden to make use of a default port for the SMTPS service. Perhaps future versions will be smart like that. Port 465 is usually what you want, and it's not a pain to specify that. WWW: http://search.cpan.org/dist/Net-SMTP-SSL/
Diffstat (limited to 'mail/p5-Net-SMTP-SSL')
-rw-r--r--mail/p5-Net-SMTP-SSL/Makefile23
-rw-r--r--mail/p5-Net-SMTP-SSL/distinfo3
-rw-r--r--mail/p5-Net-SMTP-SSL/pkg-descr7
-rw-r--r--mail/p5-Net-SMTP-SSL/pkg-plist8
4 files changed, 41 insertions, 0 deletions
diff --git a/mail/p5-Net-SMTP-SSL/Makefile b/mail/p5-Net-SMTP-SSL/Makefile
new file mode 100644
index 000000000000..e4971b516fa6
--- /dev/null
+++ b/mail/p5-Net-SMTP-SSL/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Net-SMTP-SSL
+# Date created: June 22, 2008
+# Whom: Wesley Shields <wxs@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SMTP-SSL
+PORTVERSION= 1.01
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wxs@FreeBSD.org
+COMMENT= An SMTP client supporting SSL
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SMTP::SSL.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Net-SMTP-SSL/distinfo b/mail/p5-Net-SMTP-SSL/distinfo
new file mode 100644
index 000000000000..6f100016949f
--- /dev/null
+++ b/mail/p5-Net-SMTP-SSL/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-SMTP-SSL-1.01.tar.gz) = ba039288ebf7a343feecacd374da8c1a
+SHA256 (Net-SMTP-SSL-1.01.tar.gz) = 13599c46bc7ce47fc151ace89d0625294b62154c3a20c7ff7e7614d1f2ee6289
+SIZE (Net-SMTP-SSL-1.01.tar.gz) = 1806
diff --git a/mail/p5-Net-SMTP-SSL/pkg-descr b/mail/p5-Net-SMTP-SSL/pkg-descr
new file mode 100644
index 000000000000..a1c3544e71c3
--- /dev/null
+++ b/mail/p5-Net-SMTP-SSL/pkg-descr
@@ -0,0 +1,7 @@
+Implements the same API as Net::SMTP, but uses IO::Socket::SSL for its
+network operations. Due to the nature of Net::SMTP's new method, it is
+not overridden to make use of a default port for the SMTPS service.
+Perhaps future versions will be smart like that. Port 465 is usually
+what you want, and it's not a pain to specify that.
+
+WWW: http://search.cpan.org/dist/Net-SMTP-SSL/
diff --git a/mail/p5-Net-SMTP-SSL/pkg-plist b/mail/p5-Net-SMTP-SSL/pkg-plist
new file mode 100644
index 000000000000..28d485a959fb
--- /dev/null
+++ b/mail/p5-Net-SMTP-SSL/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Net/SMTP/SSL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMTP/SSL/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMTP/SSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/Net/SMTP
+@dirrmtry %%SITE_PERL%%/Net