aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-Net-SMTP-Server/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-13 20:28:23 +0800
committeredwin <edwin@FreeBSD.org>2003-04-13 20:28:23 +0800
commit48a241b76eec811abc57f7b6cb09e19340fc862c (patch)
treede759967af3bbf8379751e686f131f856622d20e /mail/p5-Net-SMTP-Server/Makefile
parent1f26dd33c2e40b49947e66b88565d60ed8c823d6 (diff)
downloadfreebsd-ports-gnome-48a241b76eec811abc57f7b6cb09e19340fc862c.tar.gz
freebsd-ports-gnome-48a241b76eec811abc57f7b6cb09e19340fc862c.tar.zst
freebsd-ports-gnome-48a241b76eec811abc57f7b6cb09e19340fc862c.zip
Conditionalize dependencies for moudules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. 17 + 29 + 234 = 280 PRs. It's about time he starts doing the work himself! PR: ports/50588 Submitted by: Erwin Lansing <erwin@lansing.dk>
Diffstat (limited to 'mail/p5-Net-SMTP-Server/Makefile')
-rw-r--r--mail/p5-Net-SMTP-Server/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/mail/p5-Net-SMTP-Server/Makefile b/mail/p5-Net-SMTP-Server/Makefile
index 88d1cce3627e..68113abf0600 100644
--- a/mail/p5-Net-SMTP-Server/Makefile
+++ b/mail/p5-Net-SMTP-Server/Makefile
@@ -16,16 +16,22 @@ DISTNAME= SMTP-Server-${PORTVERSION}
MAINTAINER= erwin@lansing.dk
COMMENT= A native Perl SMTP Server
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
MASTER_SITE_BACKUP+= http://www.macgyver.org/software/perl/
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::SMTP::Server.3 \
Net::SMTP::Server::Client.3 \
Net::SMTP::Server::Relay.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+.endif
+
+.include <bsd.port.post.mk>