aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-qpsmtpd
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-11-25 01:40:44 +0800
committermat <mat@FreeBSD.org>2013-11-25 01:40:44 +0800
commit636603b4256acd6500e9ea55ddd74f51e9ed605d (patch)
treef9d8301a9f6d3b115d6bf94c75a45e2ab5278877 /mail/p5-qpsmtpd
parentc9f522e23f02154df2d9ac4a762e4f63f9333137 (diff)
downloadfreebsd-ports-gnome-636603b4256acd6500e9ea55ddd74f51e9ed605d.tar.gz
freebsd-ports-gnome-636603b4256acd6500e9ea55ddd74f51e9ed605d.tar.zst
freebsd-ports-gnome-636603b4256acd6500e9ea55ddd74f51e9ed605d.zip
- Wrap up cd && foo in parenthesis, it'd break with bmake -j
- Replace some FIND ... CPIO with COPYTREE_SHARE.
Diffstat (limited to 'mail/p5-qpsmtpd')
-rw-r--r--mail/p5-qpsmtpd/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/mail/p5-qpsmtpd/Makefile b/mail/p5-qpsmtpd/Makefile
index 40de795f0a7e..50f1c8fded5f 100644
--- a/mail/p5-qpsmtpd/Makefile
+++ b/mail/p5-qpsmtpd/Makefile
@@ -58,16 +58,16 @@ pre-configure:
@${RM} ${WRKSRC}/plugins/milter
post-install:
- @${MKDIR} ${DATADIR}/
+ @${MKDIR} ${DATADIR}
@${MKDIR} ${DATADIR}/plugins
- cd ${WRKSRC}/plugins/ && ${COPYTREE_SHARE} \* ${DATADIR}/plugins/
+ (cd ${WRKSRC}/plugins && ${COPYTREE_SHARE} . ${DATADIR}/plugins)
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README* ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README* ${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}/
- cd ${WRKSRC}/config.sample/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/config.sample/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>