aboutsummaryrefslogtreecommitdiffstats
path: root/mail/perdition/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-16 04:53:59 +0800
committerpav <pav@FreeBSD.org>2003-12-16 04:53:59 +0800
commit8e779a39a0012c48b1eaf7fc0d2dd168eb050a7c (patch)
treeb4011bde3d344c3f0fc5f461d90895861c7d154a /mail/perdition/Makefile
parentb7c04c03dc175976fbf5136c6f84c31bf07e5e92 (diff)
downloadfreebsd-ports-gnome-8e779a39a0012c48b1eaf7fc0d2dd168eb050a7c.tar.gz
freebsd-ports-gnome-8e779a39a0012c48b1eaf7fc0d2dd168eb050a7c.tar.zst
freebsd-ports-gnome-8e779a39a0012c48b1eaf7fc0d2dd168eb050a7c.zip
- Update to 1.12
PR: ports/60263 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org> (maintainer)
Diffstat (limited to 'mail/perdition/Makefile')
-rw-r--r--mail/perdition/Makefile53
1 files changed, 35 insertions, 18 deletions
diff --git a/mail/perdition/Makefile b/mail/perdition/Makefile
index c28afa0700e1..e51b0f8ff3d5 100644
--- a/mail/perdition/Makefile
+++ b/mail/perdition/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= perdition
-PORTVERSION= 1.11
-PORTREVISION= 2
+PORTVERSION= 1.12
CATEGORIES= mail net security
MASTER_SITES= http://www.vergenet.net/linux/perdition/download/${PORTVERSION}/
@@ -22,29 +21,31 @@ LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
MAN5= perditiondb.5
MAN8= perdition.8
-MLINK= perdition.8 - perdition.pop3s.8 \
- - perdition.imap4.8 - perdition.imap4s.8 \
- - perdition.imaps.8 - perdition.pop3.8
MANCOMPRESSED= no
USE_LIBTOOL= YES
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" BDB_LIB=db3
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= DOCSDIR=${DOCSDIR}
+CONFIGURE_ARGS+= --disable-daemon-map
INSTALLS_SHLIB= yes
-# Available knobs:
-# WITHOUT_SSL: Disable OpenSSL support
-# WITHOUT_POSIX_REGEX: Disable native regex support
-# WITH_BDB: Enable Berkerley database backend
-# WITH_NIS: Enable NIS database backend
-# WITH_GDBM: Enable gdbm database backend
-# WITH_MYSQL: Enable MySQL database backend
-# WITH_PGSQL: Enable PostgreSQL database backend
-# WITH_OPENLDAP: Enable OpenLDAP database backend
-# WITH_ODBC: Enable ODBC database backend
+##
+## Available knobs:
+## WITH_BDB: Enable Berkerley database backend
+## WITH_DAEMON_MAP: Enable Daemon Map support
+## WITH_GDBM: Enable gdbm database backend
+## WITH_MYSQL: Enable MySQL database backend
+## WITH_NIS: Enable NIS database backend
+## WITH_PGSQL: Enable PostgreSQL database backend
+## WITH_ODBC: Enable ODBC database backend
+## WITH_OPENLDAP: Enable OpenLDAP database backend
+##
+## WITHOUT_SSL: Disable OpenSSL support
+## WITHOUT_POSIX_REGEX: Disable native regex support
+##
.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --enable-ssl
@@ -55,10 +56,19 @@ CONFIGURE_ARGS+= --disable-ssl
.if !defined(WITHOUT_POSIX_REGEX)
CONFIGURE_ARGS+= --enable-posix_regex
-PLIST_SUB+= POSIX_REGEX=""
+PLIST_SUB+= POSIXREGEX=""
.else
CONFIGURE_ARGS+= --disable-posix_regex
-PLIST_SUB+= POSIX_REGEX="@comment "
+PLIST_SUB+= POSIXREGEX="@comment "
+.endif
+
+.if defined(WITH_DAEMON_MAP)
+CONFIGURE_ARGS+= --enable-daemon-map
+PLIST_SUB+= DAEMONMAP=""
+LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+.else
+CONFIGURE_ARGS+= --disable-daemon-map
+PLIST_SUB+= DAEMONMAP="@comment "
.endif
.if defined(WITH_BDB)
@@ -129,7 +139,13 @@ CONFIGURE_ARGS+= --disable-odbc
PLIST_SUB+= ODBC="@comment "
.endif
+pre-everything:: show-options
+
+show-options:
+ @${SED} -ne 's/^##//p' ${.CURDIR}/Makefile
+
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/etc/pam.d/perdition ${DOCSDIR}/perdition-pam.sample
@${ECHO_MSG} ""
@@ -138,5 +154,6 @@ post-install:
@${ECHO_MSG} " ${DOCSDIR}/perdition-pam.sample"
@${ECHO_MSG} "/********************************************************/"
@${ECHO_MSG} ""
+.endif
.include <bsd.port.mk>