aboutsummaryrefslogtreecommitdiffstats
path: root/mail/phpmailer2
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-06-02 20:15:25 +0800
committerpav <pav@FreeBSD.org>2009-06-02 20:15:25 +0800
commit0fa727f037ebd8a1b31bd15400bc8285c4f12d3d (patch)
tree3a180fe7ae4f07432934e9dc47079aca9b8c3c42 /mail/phpmailer2
parent159e52b97f752d8d0966c22b6ef0e0f2f81019fa (diff)
downloadfreebsd-ports-gnome-0fa727f037ebd8a1b31bd15400bc8285c4f12d3d.tar.gz
freebsd-ports-gnome-0fa727f037ebd8a1b31bd15400bc8285c4f12d3d.tar.zst
freebsd-ports-gnome-0fa727f037ebd8a1b31bd15400bc8285c4f12d3d.zip
PHP email transport class featuring multiple file attachments, SMTP
servers, CCs, BCCs, HTML messages, and word wrap, and more. It can send email via sendmail, PHP mail(), or with SMTP. Methods are based on the popular AspEmail active server component. WWW: http://sourceforge.net/projects/phpmailer PR: ports/135071 Submitted by: Joe Horn <joehorn@gmail.com>
Diffstat (limited to 'mail/phpmailer2')
-rw-r--r--mail/phpmailer2/Makefile51
-rw-r--r--mail/phpmailer2/distinfo3
-rw-r--r--mail/phpmailer2/files/pkg-message.in4
-rw-r--r--mail/phpmailer2/pkg-descr6
-rw-r--r--mail/phpmailer2/pkg-plist76
5 files changed, 140 insertions, 0 deletions
diff --git a/mail/phpmailer2/Makefile b/mail/phpmailer2/Makefile
new file mode 100644
index 000000000000..d52eaaa775e3
--- /dev/null
+++ b/mail/phpmailer2/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: phpmailer2
+# Date created: 30 May 2009
+# Whom: Joe Horn <joehorn@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpmailer2
+PORTVERSION= 2.0.4
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phpmailer
+DISTNAME= PHPMailer_v${DISTVERSION}
+
+MAINTAINER= joehorn@gmail.com
+COMMENT= Full Featured Email Transfer Class for PHP4
+
+CONFLICTS= phpmailer-5*
+
+USE_DOS2UNIX= yes
+NO_BUILD= yes
+USE_PHP= pcre
+
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in class.phpmailer.php class.pop3.php class.smtp.php
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DATADIR}
+.endfor
+ @${MKDIR} ${DATADIR}/language
+ @${INSTALL_DATA} ${WRKSRC}/language/* ${DATADIR}/language
+ @${MKDIR} ${DATADIR}/test
+ @${INSTALL_DATA} ${WRKSRC}/test/* ${DATADIR}/test
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in README LICENSE
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+ @${CP} -R ${WRKSRC}/docs/* ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/phpdocs/* ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/phpmailer2/distinfo b/mail/phpmailer2/distinfo
new file mode 100644
index 000000000000..db80eeb49f13
--- /dev/null
+++ b/mail/phpmailer2/distinfo
@@ -0,0 +1,3 @@
+MD5 (PHPMailer_v2.0.4.tar.gz) = c7a4ab57a06aac34f63e742323f07fc9
+SHA256 (PHPMailer_v2.0.4.tar.gz) = 012a82ca97172aa9fe15acf50464f033d341f011fd8c4e3ca90bca4a69c0c72b
+SIZE (PHPMailer_v2.0.4.tar.gz) = 154882
diff --git a/mail/phpmailer2/files/pkg-message.in b/mail/phpmailer2/files/pkg-message.in
new file mode 100644
index 000000000000..b9d8ebd9a029
--- /dev/null
+++ b/mail/phpmailer2/files/pkg-message.in
@@ -0,0 +1,4 @@
+You need to adjust php's include_path to contain `%%DATADIR%%'!
+For example, insert
+ include_path = ".:%%DATADIR%%"
+into `%%LOCALBASE%%/etc/php.ini'.
diff --git a/mail/phpmailer2/pkg-descr b/mail/phpmailer2/pkg-descr
new file mode 100644
index 000000000000..ab72e1d418ff
--- /dev/null
+++ b/mail/phpmailer2/pkg-descr
@@ -0,0 +1,6 @@
+PHP email transport class featuring multiple file attachments, SMTP servers,
+CCs, BCCs, HTML messages, and word wrap, and more. It can send email via
+sendmail, PHP mail(), or with SMTP. Methods are based on the popular AspEmail
+active server component.
+
+WWW: http://sourceforge.net/projects/phpmailer
diff --git a/mail/phpmailer2/pkg-plist b/mail/phpmailer2/pkg-plist
new file mode 100644
index 000000000000..02df3a21c67b
--- /dev/null
+++ b/mail/phpmailer2/pkg-plist
@@ -0,0 +1,76 @@
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/PHPMailer/PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/PHPMailer/POP3.html
+%%PORTDOCS%%%%DOCSDIR%%/PHPMailer/SMTP.html
+%%PORTDOCS%%%%DOCSDIR%%/PHPMailer/_v2.0.4_PHPMailer_v2.0.4_class_phpmailer_php.html
+%%PORTDOCS%%%%DOCSDIR%%/PHPMailer/_v2.0.4_PHPMailer_v2.0.4_class_pop3_php.html
+%%PORTDOCS%%%%DOCSDIR%%/PHPMailer/_v2.0.4_PHPMailer_v2.0.4_class_smtp_php.html
+%%PORTDOCS%%%%DOCSDIR%%/__filesource/fsource_PHPMailer__class.phpmailer.php.html
+%%PORTDOCS%%%%DOCSDIR%%/__filesource/fsource_PHPMailer__class.pop3.php.html
+%%PORTDOCS%%%%DOCSDIR%%/__filesource/fsource_PHPMailer__class.smtp.php.html
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/blank.html
+%%PORTDOCS%%%%DOCSDIR%%/classtrees_PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/elementindex.html
+%%PORTDOCS%%%%DOCSDIR%%/elementindex_PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/extending.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/li_PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/media/banner.css
+%%PORTDOCS%%%%DOCSDIR%%/media/stylesheet.css
+%%PORTDOCS%%%%DOCSDIR%%/packages.html
+%%PORTDOCS%%%%DOCSDIR%%/phpmailer_sm.gif
+%%PORTDOCS%%%%DOCSDIR%%/pop3_article.txt
+%%PORTDOCS%%%%DOCSDIR%%/use_gmail.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contents.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pop3_before_smtp_test.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_gmail.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_mail.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_sendmail.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_smtp.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/bkgrnd.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/phpmailer.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/phpmailer.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/phpmailer_mini.gif
+%%DATADIR%%/class.phpmailer.php
+%%DATADIR%%/class.pop3.php
+%%DATADIR%%/class.smtp.php
+%%DATADIR%%/language/phpmailer.lang-ar.php
+%%DATADIR%%/language/phpmailer.lang-br.php
+%%DATADIR%%/language/phpmailer.lang-ca.php
+%%DATADIR%%/language/phpmailer.lang-ch.php
+%%DATADIR%%/language/phpmailer.lang-cz.php
+%%DATADIR%%/language/phpmailer.lang-de.php
+%%DATADIR%%/language/phpmailer.lang-dk.php
+%%DATADIR%%/language/phpmailer.lang-en.php
+%%DATADIR%%/language/phpmailer.lang-es.php
+%%DATADIR%%/language/phpmailer.lang-et.php
+%%DATADIR%%/language/phpmailer.lang-fi.php
+%%DATADIR%%/language/phpmailer.lang-fo.php
+%%DATADIR%%/language/phpmailer.lang-fr.php
+%%DATADIR%%/language/phpmailer.lang-hu.php
+%%DATADIR%%/language/phpmailer.lang-it.php
+%%DATADIR%%/language/phpmailer.lang-ja.php
+%%DATADIR%%/language/phpmailer.lang-nl.php
+%%DATADIR%%/language/phpmailer.lang-no.php
+%%DATADIR%%/language/phpmailer.lang-pl.php
+%%DATADIR%%/language/phpmailer.lang-ro.php
+%%DATADIR%%/language/phpmailer.lang-ru.php
+%%DATADIR%%/language/phpmailer.lang-se.php
+%%DATADIR%%/language/phpmailer.lang-tr.php
+%%DATADIR%%/language/phpmailer.lang-zh.php
+%%DATADIR%%/language/phpmailer.lang-zh_cn.php
+%%DATADIR%%/test/phpmailer_test.php
+%%DATADIR%%/test/phpunit.php
+%%DATADIR%%/test/test.png
+@dirrm %%DATADIR%%/test
+@dirrm %%DATADIR%%/language
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/media
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/PHPMailer
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/__filesource
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/images
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%