aboutsummaryrefslogtreecommitdiffstats
path: root/mail/pine4/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1998-10-05 12:23:19 +0800
committersteve <steve@FreeBSD.org>1998-10-05 12:23:19 +0800
commit7a3840e68c483fcbd819e3b6439655776f1b92d4 (patch)
treeee1c2a4b7c30edf59bf3b86e41f454c3de53ff89 /mail/pine4/Makefile
parent749aebd7813511c0fbb7243c3cf2c0822095c56d (diff)
downloadfreebsd-ports-gnome-7a3840e68c483fcbd819e3b6439655776f1b92d4.tar.gz
freebsd-ports-gnome-7a3840e68c483fcbd819e3b6439655776f1b92d4.tar.zst
freebsd-ports-gnome-7a3840e68c483fcbd819e3b6439655776f1b92d4.zip
Update to version 4.05.
PR: 7993, 8151 Submitted by: maintainer
Diffstat (limited to 'mail/pine4/Makefile')
-rw-r--r--mail/pine4/Makefile40
1 files changed, 29 insertions, 11 deletions
diff --git a/mail/pine4/Makefile b/mail/pine4/Makefile
index d67059d2c339..bcc104fe965b 100644
--- a/mail/pine4/Makefile
+++ b/mail/pine4/Makefile
@@ -1,33 +1,46 @@
# New ports collection makefile for: pine
# http://www.washington.edu/pine/
-# Version required: 4.02A
+# Version required: 4.05
# Date created: 09 July 1998
# Whom: Adrian Penisoara <ady@freebsd.ady.ro>
#
-# $Id: Makefile,v 1.25 1998/07/29 16:43:59 asami Exp $
+# $Id: Makefile,v 1.26 1998/08/13 06:49:09 jkoshy Exp $
#
-DISTNAME= pine4.02
-PKGNAME= pine-4.02a
+DISTNAME= pine4.05
+PKGNAME= pine-4.05
CATEGORIES= mail news
MASTER_SITES= ftp://ftp.cac.washington.edu/pine/
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= ${DISTNAME}A.patch
-PATCH_DIST_STRIP= -p1
-
MAINTAINER= pine@freebsd.ady.ro
NO_LATEST_LINK= yes
MAN1= pine.1 pico.1 pilot.1
+post-patch:
+ for i in ${WRKSRC}/doc/pine.1 \
+ ${WRKSRC}/pine/init.c \
+ ${WRKSRC}/pine/pine.hlp \
+ ${WRKSRC}/pine/mailcap.c \
+ ${WRKSRC}/pine/osdep/os-bsf.h ; do \
+ ${MV} $$i $$i.sed ; \
+ ${SED} -e "s:@@PREFIX@@:${PREFIX}:g" \
+ $$i.sed >$$i ; \
+ ${RM} $$i.sed ; \
+ done
+ for i in ${WRKSRC}/doc/tech-notes.txt \
+ ${WRKSRC}/doc/tech-notes/*.html ; do \
+ ${MV} $$i $$i.sed ; \
+ ${SED} -e "s:/usr/local/lib/:${PREFIX}/etc/:g" \
+ $$i.sed >$$i ; \
+ ${RM} $$i.sed ; \
+ done
+
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ./build bsf)
do-install:
- ${INSTALL} ${COPY} -o ${LIBOWN} -g ${LIBGRP} -m ${LIBMODE} \
- ${WRKSRC}/bin/libpico.so.2.0 ${PREFIX}/lib/libpico.so.2.0
${INSTALL_PROGRAM} ${WRKSRC}/bin/pico ${PREFIX}/bin/pico
${INSTALL_PROGRAM} ${WRKSRC}/bin/pilot ${PREFIX}/bin/pilot
${INSTALL_PROGRAM} ${WRKSRC}/bin/pine ${PREFIX}/bin/pine
@@ -50,6 +63,11 @@ do-install:
.endif
post-install:
- ${LDCONFIG} -m ${PREFIX}/lib/
+ ${PREFIX}/bin/pine -P ${PREFIX}/etc/pine.conf -conf >${WRKSRC}/pine.conf
+ ${INSTALL_DATA} ${WRKSRC}/pine.conf ${PREFIX}/etc/pine.conf
+ @${ECHO} " - - - - - - - - - - - - - - - - - - - - - - - - -"
+ @${ECHO} " If Pine exits with \"Received abort signal\" try"
+ @${ECHO} " disabling the \"quell-folder-internal-msg\" feature"
+ @${ECHO} " - - - - - - - - - - - - - - - - - - - - - - - - -"
.include <bsd.port.mk>