aboutsummaryrefslogtreecommitdiffstats
path: root/mail/pine4
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2005-10-12 08:20:19 +0800
committerdougb <dougb@FreeBSD.org>2005-10-12 08:20:19 +0800
commite3cfcadf201b8db38678bd25230a6b2825cf954c (patch)
treec2f33464c3d14d5c0a0428065f585bf058c0422d /mail/pine4
parent92c4dd47debef76ed638673390bf0b4d7b39550a (diff)
downloadfreebsd-ports-gnome-e3cfcadf201b8db38678bd25230a6b2825cf954c.tar.gz
freebsd-ports-gnome-e3cfcadf201b8db38678bd25230a6b2825cf954c.tar.zst
freebsd-ports-gnome-e3cfcadf201b8db38678bd25230a6b2825cf954c.zip
Update Pine and Pico to 4.64, the latest from UW. This version contains
mostly bug fixes, with a few small new features. See the following for details: http://www.washington.edu/pine/changes/4.63-to-4.64.html I also updated the Pine port to stop building Pico, and instead depend on the Pico port. This solves a CONFLICTS situation, and is arguably the more logical way to handle this. Also, if you use an alternate editor for Pine, you no longer have to install Pico if you don't want it. Make the dependency on ispell conditional. [1] This is not exactly what the PR originator requested, but it will accomplish basically the same thing. Use these new things called variables to help ensure that the maildir patches can be found from version to version. [2] PR [1]: ports/75569 Submitted by [1]: Jeremy Chadwick <freebsd@jdc.parodius.com> PR [2]: ports/86960 Submitted by [2]: Lewis Thompson <lewiz@compsoc.man.ac.uk>
Diffstat (limited to 'mail/pine4')
-rw-r--r--mail/pine4/Makefile15
-rw-r--r--mail/pine4/distinfo6
-rw-r--r--mail/pine4/files/patch-aa31
-rw-r--r--mail/pine4/files/patch-al39
-rw-r--r--mail/pine4/files/patch-an31
-rw-r--r--mail/pine4/files/patch-ap20
-rw-r--r--mail/pine4/files/patch-as57
-rw-r--r--mail/pine4/files/patch-bd11
-rw-r--r--mail/pine4/files/patch-pico_makefile.bsf13
-rw-r--r--mail/pine4/pkg-plist1
10 files changed, 59 insertions, 165 deletions
diff --git a/mail/pine4/Makefile b/mail/pine4/Makefile
index b740ab345492..3cdf57904951 100644
--- a/mail/pine4/Makefile
+++ b/mail/pine4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pine
-PORTVERSION= 4.63
+PORTVERSION= 4.64
CATEGORIES= mail news ipv6
MASTER_SITES= ftp://ftp.cac.washington.edu/pine/ \
http://mirror.sit.wisc.edu/pub/net/mail/pine/ \
@@ -20,7 +20,13 @@ DISTNAME= pine${PORTVERSION}
MAINTAINER= DougB@FreeBSD.org
COMMENT= PINE(tm) -- a Program for Internet News & Email
-RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
+.if !defined(WITHOUT_ISPELL)
+RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
+.endif
+
+.if !defined(WITHOUT_PICO)
+RUN_DEPENDS+= pico:${PORTSDIR}/editors/pico
+.endif
.if defined(WITH_LDAP)
USE_OPENLDAP= yes
@@ -48,14 +54,14 @@ EXTRA_OPTS+= SSLTYPE=unix.nopwd
EXTRA_OPTS+= IP=6
.endif
-MAN1= pine.1 pico.1 pilot.1 rpdump.1 rpload.1
+MAN1= pine.1 pilot.1 rpdump.1 rpload.1
pre-fetch:
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
${SH} pkg-install
.endif
.if defined(WITH_MAILDIR)
-PATCH_SITES= http://www.math.washington.edu/~chappa/pine/patches/pine4.62/
+PATCH_SITES= http://www.math.washington.edu/~chappa/pine/patches/pine${PORTVERSION}/
PATCHFILES= maildir.patch.gz
PATCH_DIST_ARGS+= -E --quiet -d ${PATCH_WRKSRC} -p1
.endif
@@ -73,7 +79,6 @@ post-patch:
.endfor
@for i in ${WRKSRC}/README ${WRKSRC}/doc/pine.1 \
${WRKSRC}/doc/tech-notes.txt ${WRKSRC}/doc/tech-notes/*.html \
- ${WRKSRC}/pico/osdep/os-bsf.h \
${WRKSRC}/pine/init.c ${WRKSRC}/pine/mailcap.c \
${WRKSRC}/pine/osdep/os-bsf.h ${WRKSRC}/pine/pine.hlp ; do \
${CP} $$i $$i.presed ; \
diff --git a/mail/pine4/distinfo b/mail/pine4/distinfo
index 8a23015ad614..d18d22846ee1 100644
--- a/mail/pine4/distinfo
+++ b/mail/pine4/distinfo
@@ -1,4 +1,2 @@
-MD5 (pine4.63.tar.gz) = 0cd94e17c10eef0d43966635a328fe64
-SIZE (pine4.63.tar.gz) = 4143825
-MD5 (maildir.patch.gz) = 7bd660ec40a36c10453634f8be6ad3b4
-SIZE (maildir.patch.gz) = 28723
+MD5 (pine4.64.tar.gz) = 9cc68749675f1c35a2147a35d2c5b344
+SIZE (pine4.64.tar.gz) = 4218629
diff --git a/mail/pine4/files/patch-aa b/mail/pine4/files/patch-aa
deleted file mode 100644
index b6de406f8fc8..000000000000
--- a/mail/pine4/files/patch-aa
+++ /dev/null
@@ -1,31 +0,0 @@
---- pico/search.c.orig Thu Jun 21 10:50:05 2001
-+++ pico/search.c Fri Sep 28 00:08:23 2001
-@@ -98,12 +98,15 @@
- int bc;
- int pc;
- {
-+ bc = (unsigned char)bc;
-+ pc = (unsigned char)pc;
-+
- if ((curwp->w_bufp->b_mode & MDEXACT) == 0){
-- if (bc>='a' && bc<='z')
-- bc -= 0x20;
-+ if (islower(bc))
-+ bc = toupper(bc);
-
-- if (pc>='a' && pc<='z')
-- pc -= 0x20;
-+ if (islower(pc))
-+ pc = toupper(pc);
- }
-
- return(bc == pc);
-@@ -805,7 +808,7 @@
- int maxlength; /* maximum chars in destination */
-
- {
-- char c; /* current char to translate */
-+ unsigned char c; /* current char to translate */
-
- /* scan through the string */
- while ((c = *srcstr++) != 0) {
diff --git a/mail/pine4/files/patch-al b/mail/pine4/files/patch-al
index d7fbfa5d9c0b..c8302e60a278 100644
--- a/mail/pine4/files/patch-al
+++ b/mail/pine4/files/patch-al
@@ -1,11 +1,40 @@
---- build.orig Mon Dec 9 09:54:38 2002
-+++ build Thu Jan 16 00:42:58 2003
-@@ -450,7 +450,7 @@
+--- build.orig Wed May 4 14:22:22 2005
++++ build Tue Oct 11 15:49:30 2005
+@@ -451,7 +451,7 @@
+ fi
+ echo ''
+
+- echo "Making Pico and Pilot"
++ echo "Making Pilot"
+ cd "$PHOME/pico"
+ eval echo make "$makeargs" -f makefile.$picotarg
+ eval make "$makeargs" -f makefile.$picotarg
+@@ -480,14 +480,13 @@
+ cd "$PHOME"
+ if [ ! -d bin ] ; then mkdir bin; fi
+ cd "$PHOME/bin"
+- rm -f pine mtest imapd mailutil pico pilot rpload rpdump ipop2d ipop3d
++ rm -f pine mtest imapd mailutil pilot rpload rpdump ipop2d ipop3d
+ if [ -s ../pine/pine ] ; then ln ../pine/pine pine ; fi
+ if [ -s ../mtest/mtest ] ; then ln ../mtest/mtest mtest ; fi
+ if [ -s ../mailutil/mailutil ] ; then ln ../mailutil/mailutil mailutil ; fi
+ if [ -s ../imapd/imapd ] ; then ln ../imapd/imapd imapd ; fi
+ if [ -s ../ipopd/ipop2d ] ; then ln ../ipopd/ipop2d ipop2d ; fi
+ if [ -s ../ipopd/ipop3d ] ; then ln ../ipopd/ipop3d ipop3d ; fi
+- if [ -s ../pico/pico ] ; then ln ../pico/pico pico ; fi
+ if [ -s ../pico/pilot ] ; then ln ../pico/pilot pilot ; fi
+ if [ -s ../pine/rpload ] ; then ln ../pine/rpload rpload ; fi
+ if [ -s ../pine/rpdump ] ; then ln ../pine/rpdump rpdump ; fi
+@@ -502,10 +501,10 @@
cd "$PHOME"
echo ''
echo "Links to executables are in bin directory:"
- size bin/pine bin/mtest bin/imapd bin/pico bin/pilot bin/rpdump bin/rpload bin/mailutil bin/ipop2d bin/ipop3d
-+ size bin/pine bin/pico bin/pilot bin/rpdump bin/rpload
++ size bin/pine bin/pilot bin/rpdump bin/rpload
case $maketarg in
mnt) echo "Fixing stacksizes ..."
- fixstk 64K bin/pine bin/pico bin/imapd bin/mtest bin/pilot
+- fixstk 64K bin/pine bin/pico bin/imapd bin/mtest bin/pilot
++ fixstk 64K bin/pine bin/pilot
+ esac
+ if [ "$SSLWARN" = "1" ]
+ then
diff --git a/mail/pine4/files/patch-an b/mail/pine4/files/patch-an
deleted file mode 100644
index d458616a3b76..000000000000
--- a/mail/pine4/files/patch-an
+++ /dev/null
@@ -1,31 +0,0 @@
-*** pico/osdep/os-bsf.h.orig Wed Feb 7 14:53:26 2001
---- pico/osdep/os-bsf.h Wed Mar 5 04:24:00 2003
-***************
-*** 153,165 ****
- /*
- * Place where mail gets delivered (for pico's new mail checking)
- */
-! #define MAILDIR "/usr/spool/mail"
-
- /*
- * What and where the tool that checks spelling is located. If this is
- * undefined, then the spelling checker is not compiled into pico.
- */
-! #define SPELLER "/usr/bin/spell"
-
- #ifdef MOUSE
- #define XTERM_MOUSE_ON "\033[?1000h" /* DECSET with parm 1000 */
---- 153,165 ----
- /*
- * Place where mail gets delivered (for pico's new mail checking)
- */
-! #define MAILDIR "/var/mail"
-
- /*
- * What and where the tool that checks spelling is located. If this is
- * undefined, then the spelling checker is not compiled into pico.
- */
-! #define SPELLER "@@PREFIX@@/bin/spell"
-
- #ifdef MOUSE
- #define XTERM_MOUSE_ON "\033[?1000h" /* DECSET with parm 1000 */
diff --git a/mail/pine4/files/patch-ap b/mail/pine4/files/patch-ap
deleted file mode 100644
index f41ce128e49e..000000000000
--- a/mail/pine4/files/patch-ap
+++ /dev/null
@@ -1,20 +0,0 @@
-*** pico/osdep/term.cap.orig Thu Nov 14 09:27:17 2002
---- pico/osdep/term.cap Fri Sep 5 01:44:21 2003
-***************
-*** 288,294 ****
- _kppu = tgetstr("kP", &p);
- _kppd = tgetstr("kN", &p);
- _kphome = tgetstr("kh", &p);
-! _kpend = tgetstr("kH", &p);
- _kpdel = tgetstr("kD", &p);
- _kf1 = tgetstr("k1", &p);
- _kf2 = tgetstr("k2", &p);
---- 288,295 ----
- _kppu = tgetstr("kP", &p);
- _kppd = tgetstr("kN", &p);
- _kphome = tgetstr("kh", &p);
-! if((_kpend = tgetstr("@7", &p)) == NULL)
-! _kpend = tgetstr("kH",&p);
- _kpdel = tgetstr("kD", &p);
- _kf1 = tgetstr("k1", &p);
- _kf2 = tgetstr("k2", &p);
diff --git a/mail/pine4/files/patch-as b/mail/pine4/files/patch-as
deleted file mode 100644
index 0a5cc4d1d2e2..000000000000
--- a/mail/pine4/files/patch-as
+++ /dev/null
@@ -1,57 +0,0 @@
-*** pico/edef.h.orig Thu Apr 23 02:53:44 1998
---- pico/edef.h Tue Feb 9 22:14:08 1999
-***************
-*** 59,65 ****
- int ComposerEditing = FALSE; /* TRUE if message line is open */
- int revexist = FALSE; /* does reverse video exist? */
- char modecode[] = "WCSEVO"; /* letters to represent modes */
-! long gmode = MDWRAP; /* global editor mode */
- int sgarbf = TRUE; /* TRUE if screen is garbage */
- int mpresf = FALSE; /* TRUE if message in last line */
- int clexec = FALSE; /* command line execution flag */
---- 59,65 ----
- int ComposerEditing = FALSE; /* TRUE if message line is open */
- int revexist = FALSE; /* does reverse video exist? */
- char modecode[] = "WCSEVO"; /* letters to represent modes */
-! long gmode = MDWRAP | MDTCAPWINS; /* global editor mode */
- int sgarbf = TRUE; /* TRUE if screen is garbage */
- int mpresf = FALSE; /* TRUE if message in last line */
- int clexec = FALSE; /* command line execution flag */
-*** pico/main.c.orig Tue Feb 9 21:46:54 1999
---- pico/main.c Tue Feb 9 22:14:08 1999
-***************
-*** 443,449 ****
- gmode ^= MDSSPD;
- break;
- case 'q': /* -q for termcap takes precedence */
-! gmode ^= MDTCAPWINS;
- break;
- case 'w': /* -w turn off word wrap */
- gmode ^= MDWRAP;
---- 443,449 ----
- gmode ^= MDSSPD;
- break;
- case 'q': /* -q for termcap takes precedence */
-! gmode |= MDTCAPWINS;
- break;
- case 'w': /* -w turn off word wrap */
- gmode ^= MDWRAP;
-*** pico/pilot.c.orig Mon Aug 24 20:37:39 1998
---- pico/pilot.c Tue Feb 9 22:14:09 1999
-***************
-*** 222,228 ****
- sup_keyhelp = !sup_keyhelp;
- break;
- case 'q': /* -q for termcap takes precedence */
-! gmode ^= MDTCAPWINS;
- break;
- case 'z': /* -z to suspend */
- gmode ^= MDSSPD;
---- 222,228 ----
- sup_keyhelp = !sup_keyhelp;
- break;
- case 'q': /* -q for termcap takes precedence */
-! gmode |= MDTCAPWINS;
- break;
- case 'z': /* -z to suspend */
- gmode ^= MDSSPD;
diff --git a/mail/pine4/files/patch-bd b/mail/pine4/files/patch-bd
deleted file mode 100644
index 9e760bc21447..000000000000
--- a/mail/pine4/files/patch-bd
+++ /dev/null
@@ -1,11 +0,0 @@
---- pico/makefile.bsf.orig Sun Feb 11 20:15:44 2001
-+++ pico/makefile.bsf Sun Feb 11 20:15:18 2001
-@@ -37,7 +37,7 @@
- DEBUG= -DDEBUG # -g
-
- STDCFLAGS= -DBSDI -DBSDI2 -DPOSIX -DJOB_CONTROL -DMOUSE
--CFLAGS= $(OPTIMIZE) $(PROFILE) $(DEBUG) $(EXTRACFLAGS) $(STDCFLAGS)
-+CFLAGS+= $(OPTIMIZE) $(PROFILE) $(DEBUG) $(EXTRACFLAGS) $(STDCFLAGS)
-
- # switches for library building
- LIBCMD= ar
diff --git a/mail/pine4/files/patch-pico_makefile.bsf b/mail/pine4/files/patch-pico_makefile.bsf
new file mode 100644
index 000000000000..e650ceb714d5
--- /dev/null
+++ b/mail/pine4/files/patch-pico_makefile.bsf
@@ -0,0 +1,13 @@
+--- pico/makefile.bsf.orig Tue Oct 23 15:18:36 2001
++++ pico/makefile.bsf Tue Oct 11 15:52:20 2005
+@@ -56,8 +56,8 @@
+ #
+ # dependencies for the Unix versions of pico and libpico.a
+ #
+-all: pico pilot
+-pico pilot: libpico.a
++all: pilot
++pilot: libpico.a
+
+ pico: main.o
+ $(CC) $(CFLAGS) main.o libpico.a $(LIBS) -o pico
diff --git a/mail/pine4/pkg-plist b/mail/pine4/pkg-plist
index c3ae80816d9d..f042a96a05eb 100644
--- a/mail/pine4/pkg-plist
+++ b/mail/pine4/pkg-plist
@@ -1,7 +1,6 @@
@unexec %D/bin/pine -conf >%D/etc/pine.conf.tmp
@unexec if cmp -s %D/etc/pine.conf %D/etc/pine.conf.tmp; then rm -f %D/etc/pine.conf; fi
@unexec rm -f %D/etc/pine.conf.tmp
-bin/pico
bin/pilot
bin/pine
bin/rpdump