aboutsummaryrefslogtreecommitdiffstats
path: root/mail/policyd/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-22 11:43:31 +0800
committeredwin <edwin@FreeBSD.org>2004-12-22 11:43:31 +0800
commit29e073c8486855bef961a2bfdab08b4f22e78d0a (patch)
tree4153da1feb83639d21c90359b3e1c281f1de7598 /mail/policyd/Makefile
parente62fc027fbe3d6df537c46eb590f00807ba62b1b (diff)
downloadfreebsd-ports-gnome-29e073c8486855bef961a2bfdab08b4f22e78d0a.tar.gz
freebsd-ports-gnome-29e073c8486855bef961a2bfdab08b4f22e78d0a.tar.zst
freebsd-ports-gnome-29e073c8486855bef961a2bfdab08b4f22e78d0a.zip
New port: mail/policyd Implements SPF for postfix, as a policy daemon
This port implements SPF for Postfix, without include anothers libraries in postfix port. PR: ports/75284 Submitted by: Marcus Grando <marcus@corp.grupos.com.br>
Diffstat (limited to 'mail/policyd/Makefile')
-rw-r--r--mail/policyd/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/mail/policyd/Makefile b/mail/policyd/Makefile
new file mode 100644
index 000000000000..c47b86cb20d4
--- /dev/null
+++ b/mail/policyd/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: policyd
+# Date created: 19 Dec 2004
+# Whom: Marcus Grando <marcus@corp.grupos.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= policyd
+PORTVERSION= 1.0.1
+CATEGORIES= mail
+MASTER_SITES= http://www.libspf2.org/patch/
+
+MAINTAINER= marcus@corp.grupos.com.br
+COMMENT= Implements SPF for postfix, as a policy daemon
+
+LIB_DEPENDS= spf2.1:${PORTSDIR}/mail/libspf2
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+GNU_CONFIGURE= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>