aboutsummaryrefslogtreecommitdiffstats
path: root/mail/popd
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2003-06-24 20:56:12 +0800
committersheldonh <sheldonh@FreeBSD.org>2003-06-24 20:56:12 +0800
commit0d527033d9bc862646675632be61108be2b03db0 (patch)
treeeb310fbc7dc9066d4b99ab10ec78c9bffc0d1e8d /mail/popd
parent02b0b5951fc19e7b6121a9308fe26910365dd312 (diff)
downloadfreebsd-ports-gnome-0d527033d9bc862646675632be61108be2b03db0.tar.gz
freebsd-ports-gnome-0d527033d9bc862646675632be61108be2b03db0.tar.zst
freebsd-ports-gnome-0d527033d9bc862646675632be61108be2b03db0.zip
Fix a bug in UIDL handling for maildir boxes, which could lead to clients
receiving duplicated messages. Submitted by: author
Diffstat (limited to 'mail/popd')
-rw-r--r--mail/popd/Makefile1
-rw-r--r--mail/popd/files/patch-lib::mbox_maildir.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/popd/Makefile b/mail/popd/Makefile
index 5d376953bca9..75610c17dc99 100644
--- a/mail/popd/Makefile
+++ b/mail/popd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= popd
PORTVERSION= 2.2.2a
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp3.za.freebsd.org/pub/popd/
diff --git a/mail/popd/files/patch-lib::mbox_maildir.c b/mail/popd/files/patch-lib::mbox_maildir.c
new file mode 100644
index 000000000000..e3a164cb8f2d
--- /dev/null
+++ b/mail/popd/files/patch-lib::mbox_maildir.c
@@ -0,0 +1,11 @@
+--- lib/mbox_maildir.c.orig Tue Jun 24 14:37:19 2003
++++ lib/mbox_maildir.c Tue Jun 24 14:38:18 2003
+@@ -190,7 +190,7 @@
+ (MDIR_F_EXPIRE | MDIR_F_REMOVE) &&
+ cxn->flags & MAILBOX_F_FALSEUIDL ?
+ time(NULL) : mbox->msg[mbox->count].d_time,
+- mbox->msg[mbox->count].path,
++ dp->d_name,
+ mbox->msg[mbox->count].bytes);
+ MD5Init(&context);
+ MD5Update(&context, (unsigned char *)uidldat,