aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix-current
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-05-29 21:36:22 +0800
committerijliao <ijliao@FreeBSD.org>2001-05-29 21:36:22 +0800
commit43e573cc1067b4e6d6c98c204e8389752d33ea83 (patch)
tree9815601a474f8869bc22d3d84831e9cb4bbbcc76 /mail/postfix-current
parent99345815e95bd43c3089af11d1379b68a2779b00 (diff)
downloadfreebsd-ports-gnome-43e573cc1067b4e6d6c98c204e8389752d33ea83.tar.gz
freebsd-ports-gnome-43e573cc1067b4e6d6c98c204e8389752d33ea83.tar.zst
freebsd-ports-gnome-43e573cc1067b4e6d6c98c204e8389752d33ea83.zip
Detect if sasl is compiled with mysql
Compile mysql support static because it won't startup on boot if you don't PR: 27597 Submitted by: maintainer
Diffstat (limited to 'mail/postfix-current')
-rw-r--r--mail/postfix-current/Makefile4
-rw-r--r--mail/postfix-current/scripts/configure.postfix4
2 files changed, 7 insertions, 1 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index d995e9149e01..5aa875de10a6 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 20010502
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/ \
ftp://ftp.aet.tu-cottbus.de/pub/postfix_tls/%SUBDIR%/ \
@@ -62,7 +63,8 @@ MAKEFILEFLAGS+= OPT="${CFLAGS}"
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
PREFIX="${PREFIX}" \
TOUCH="${TOUCH}" \
- MKDIR="${MKDIR}"
+ MKDIR="${MKDIR}" \
+ PREFIX="${PREFIX}"
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.postfix
diff --git a/mail/postfix-current/scripts/configure.postfix b/mail/postfix-current/scripts/configure.postfix
index ab402f363473..1c8ba2508a25 100644
--- a/mail/postfix-current/scripts/configure.postfix
+++ b/mail/postfix-current/scripts/configure.postfix
@@ -68,6 +68,10 @@ while [ "$1" ]; do
echo "BUILD_DEPENDS+= \${LOCALBASE}/lib/libsasl.a:\${PORTSDIR}/security/cyrus-sasl"
echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include"
echo "POSTFIX_AUXLIBS+= \${LOCALBASE}/lib/libsasl.a -lpam -lcrypt"
+ if [ `strings ${PREFIX}/lib/libsasl.a | grep mysql_verify_password` = "mysql_verify_password" ]; then
+ echo "POSTFIX_CCARGS+= -DHAS_MYSQL -I\${LOCALBASE}/include/mysql"
+ echo "POSTFIX_AUXLIBS+= \${LOCALBASE}/lib/mysql/libmysqlclient.a -lm -lz"
+ fi
echo ".if exists(/usr/lib/libkrb.a)"
echo "POSTFIX_AUXLIBS+= -lkrb -ldes -lcom_err"
echo ".endif"