aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix-gps/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-23 15:08:17 +0800
committeredwin <edwin@FreeBSD.org>2004-12-23 15:08:17 +0800
commit0d96d3a55a54cd83ecf2d0550062d9c38554bad8 (patch)
tree5b266b45bdcfed1ef7d5013b7183df15551fdecd /mail/postfix-gps/Makefile
parentdb4608cc0aa4491debc397bff28de6dbce1b20c2 (diff)
downloadfreebsd-ports-gnome-0d96d3a55a54cd83ecf2d0550062d9c38554bad8.tar.gz
freebsd-ports-gnome-0d96d3a55a54cd83ecf2d0550062d9c38554bad8.tar.zst
freebsd-ports-gnome-0d96d3a55a54cd83ecf2d0550062d9c38554bad8.zip
[NEW PORT]: mail/postfix-gps
This is a shar(1) archive for a new port, postfix-gps, which implements a database based greylisting add-in for postfix. PR: ports/71912 Submitted by: Xin LI <delphij@freebsd.org>
Diffstat (limited to 'mail/postfix-gps/Makefile')
-rw-r--r--mail/postfix-gps/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/mail/postfix-gps/Makefile b/mail/postfix-gps/Makefile
new file mode 100644
index 000000000000..8c48735e4bdf
--- /dev/null
+++ b/mail/postfix-gps/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: postfix-gps
+# Date created: 2 September 2004
+# Whom: Xin LI <delphij@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gps
+PORTVERSION= 0.9
+CATEGORIES= mail security
+MASTER_SITES= http://mimo.gn.apc.org/gps/
+PKGNAMEPREFIX= postfix-
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
+ ${SCRIPT_FILES}
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= delphij@FreeBSD.org
+COMMENT= Greylist Policy Service for postfix
+
+LIB_DEPENDS= dbi.0:${PORTSDIR}/databases/libdbi
+RUN_DEPENDS= ${LOCALBASE}/lib/dbd:${PORTSDIR}/databases/libdbi-drivers
+
+SCRIPT_FILES= gps-maintain.pl
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_AUTOCONF_VER= 259
+USE_AUTOMAKE_VER= 19
+USE_GCC= 3.3
+CONFIGURE_ARGS= --bindir=${PREFIX}/libexec --includedir=${PREFIX}/include
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${PREFIX}/include" \
+ CXXFLAGS="${CXXFLAGS} -I${PREFIX}/include" \
+ LDFLAGS="${LDFLAGS} -L${PREFIX}/lib"
+
+pre-configure:
+ @cd ${WRKSRC} && ${ACLOCAL}
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/etc/gps.conf ${PREFIX}/etc/gps.conf-dist
+.for f in ${SCRIPT_FILES}
+ @${INSTALL_SCRIPT} ${_DISTDIR}/${f} ${PREFIX}/libexec
+.endfor
+ @${PAGER} pkg-message
+
+.include <bsd.port.mk>