aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix-policyd-weight/Makefile
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2015-01-10 04:59:09 +0800
committerohauer <ohauer@FreeBSD.org>2015-01-10 04:59:09 +0800
commit199e51b89380871fe7ab9043e5d1941cee28f834 (patch)
tree25397f952369bb08cdfa6b5c93b3be7d3689ead2 /mail/postfix-policyd-weight/Makefile
parent81fa8909bd5943caf5c1c6d2c12bbdf2b84b6921 (diff)
downloadfreebsd-ports-gnome-199e51b89380871fe7ab9043e5d1941cee28f834.tar.gz
freebsd-ports-gnome-199e51b89380871fe7ab9043e5d1941cee28f834.tar.zst
freebsd-ports-gnome-199e51b89380871fe7ab9043e5d1941cee28f834.zip
- remove dead rhsbl.ahbl.org [1]
- install policyd-weight.conf with the @sample macro - alert user if any of this deprecated lists is found in policyd-weight.conf dnsbl.njabl.org rbl.ipv6-world.net rhsbl.ahbl.org dsn.rfc-ignorant.org postmaster.rfc-ignorant.org abuse.rfc-ignorant.org [1] Noted by: Herbert J. Skuhra MFH: 2015Q1
Diffstat (limited to 'mail/postfix-policyd-weight/Makefile')
-rw-r--r--mail/postfix-policyd-weight/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/mail/postfix-policyd-weight/Makefile b/mail/postfix-policyd-weight/Makefile
index 3ec89398681c..6727257ed5cd 100644
--- a/mail/postfix-policyd-weight/Makefile
+++ b/mail/postfix-policyd-weight/Makefile
@@ -3,7 +3,7 @@
PORTNAME= policyd-weight
PORTVERSION= 0.1.15.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://www.policyd-weight.org/releases/ \
LOCAL/ohauer
@@ -17,8 +17,9 @@ LICENSE= GPLv2
RUN_DEPENDS= p5-Net-DNS>=0.72:${PORTSDIR}/dns/p5-Net-DNS \
p5-Net-IP>0:${PORTSDIR}/net-mgmt/p5-Net-IP
-SUB_FILES= pkg-message
-PLIST_FILES= bin/${PORTNAME} etc/${PORTNAME}.conf.sample \
+SUB_FILES= pkg-message pkg-install
+PLIST_FILES= bin/${PORTNAME} \
+ "@sample etc/${PORTNAME}.conf.sample" \
man/man5/policyd-weight.conf.5.gz \
man/man8/policyd-weight.8.gz
@@ -31,9 +32,9 @@ USE_PERL5= run
NO_BUILD= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${STAGEDIR}${PREFIX}/etc/
- ${INSTALL_MAN} ${WRKSRC}/man/man5/policyd-weight.conf.5 ${STAGEDIR}${MAN5PREFIX}/man/man5/
- ${INSTALL_MAN} ${WRKSRC}/man/man8/policyd-weight.8 ${STAGEDIR}${MAN8PREFIX}/man/man8/
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${STAGEDIR}${PREFIX}/etc
+ ${INSTALL_MAN} ${WRKSRC}/man/man5/policyd-weight.conf.5 ${STAGEDIR}${MAN5PREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/man/man8/policyd-weight.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
.include <bsd.port.mk>