aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix-postfwd/Makefile
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-05-21 09:54:45 +0800
committerbeech <beech@FreeBSD.org>2008-05-21 09:54:45 +0800
commit3b6ef3dc911a61b3ed0aef622dcde6575c913225 (patch)
tree86f773a2460a15de25e2fefe3afbb16db6dba494 /mail/postfix-postfwd/Makefile
parent828edb356aa24660a8992e66645e2caca43f12c7 (diff)
downloadfreebsd-ports-gnome-3b6ef3dc911a61b3ed0aef622dcde6575c913225.tar.gz
freebsd-ports-gnome-3b6ef3dc911a61b3ed0aef622dcde6575c913225.tar.zst
freebsd-ports-gnome-3b6ef3dc911a61b3ed0aef622dcde6575c913225.zip
- New port: mail/postfix-postfwd A postfix firewall policy daemon
The program uses the postfix policy delegation protocol to control access to the mail system before a message has been accepted (please visit http://www.postfix.org/SMTPD_POLICY_README.html for more information). It allows you to choose an action (e.g. reject, dunno) for a combination of several smtp parameters (like sender and recipient address, size or the client's TLS fingerprint). PR: ports/123544 Submitted by: Sahil Tandon <sahil at tandon.net>
Diffstat (limited to 'mail/postfix-postfwd/Makefile')
-rw-r--r--mail/postfix-postfwd/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/mail/postfix-postfwd/Makefile b/mail/postfix-postfwd/Makefile
new file mode 100644
index 000000000000..f4239cb0bdbd
--- /dev/null
+++ b/mail/postfix-postfwd/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: postfwd
+# Date created: 8 May 2008
+# Whom: Sahil Tandon <sahil@tandon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postfwd
+DISTVERSION= 1.10.7b
+CATEGORIES= mail
+MASTER_SITES= http://www.postfwd.org/old/
+PKGNAMEPREFIX= postfix-
+DISTNAME= postfwd-1.10pre7b
+
+MAINTAINER= sahil@tandon.net
+COMMENT= A postfix firewall policy daemon
+
+RUN_DEPENDS= ${SITE_PERL}/Net/DNS/Async.pm:${PORTSDIR}/dns/p5-Net-DNS-Async \
+ ${SITE_PERL}/Net/CIDR/Lite.pm:${PORTSDIR}/net/p5-Net-CIDR-Lite \
+ ${SITE_PERL}/IO/Multiplex.pm:${PORTSDIR}/devel/p5-IO-Multiplex
+
+PORTDOCS= CHANGELOG postfwd.html postfwd.txt
+PORTEXAMPLES= postfwd-rblcheck.pl request.sample
+PLIST_FILES= bin/postfwd etc/postfwd.conf.sample
+
+SUB_FILES= pkg-message
+
+USE_RC_SUBR= postfwd
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+MAN1= postfwd.1
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/sbin/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_DATA} ${WRKSRC}/etc/${PORTNAME}.cf ${PREFIX}/etc/${PORTNAME}.conf.sample
+ @${INSTALL_MAN} ${WRKSRC}/man/man1/${MAN1} ${MANPREFIX}/man/man1/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC}/doc/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${INSTALL} -d ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/bin/postfwd-rblcheck.pl ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/tools/request.sample ${EXAMPLESDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>