aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix25/Makefile
diff options
context:
space:
mode:
authortorstenb <torstenb@FreeBSD.org>2000-01-29 05:07:45 +0800
committertorstenb <torstenb@FreeBSD.org>2000-01-29 05:07:45 +0800
commit47543cc28fbf966606d2815b75455491b11ebb6d (patch)
tree9f46a3576a8a964b8bf3c87581ef46df9a96a1ac /mail/postfix25/Makefile
parente1a0cc6e6430206eaf4785de011f100e8ab4a6f1 (diff)
downloadfreebsd-ports-gnome-47543cc28fbf966606d2815b75455491b11ebb6d.tar.gz
freebsd-ports-gnome-47543cc28fbf966606d2815b75455491b11ebb6d.tar.zst
freebsd-ports-gnome-47543cc28fbf966606d2815b75455491b11ebb6d.zip
- Upgrade to patchlevel 3
- Add support for MySQL and LDAP support MySQL + LDAP Patches submitted by Blaz Zupan <blaz@amis.net> and re-used with minor cleanups.
Diffstat (limited to 'mail/postfix25/Makefile')
-rw-r--r--mail/postfix25/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/mail/postfix25/Makefile b/mail/postfix25/Makefile
index b1b572416f97..29d646dd163e 100644
--- a/mail/postfix25/Makefile
+++ b/mail/postfix25/Makefile
@@ -6,7 +6,8 @@
# $FreeBSD$
#
-DISTNAME= postfix-19991231
+DISTNAME= postfix-19991231-pl03
+PKGNAME= postfix-19991231.03
CATEGORIES= mail
MASTER_SITES= ftp://ftp.merit.edu/postfix/official/ \
ftp://ftp.snoopy.net/pub/mirrors/postfix/official/ \
@@ -20,6 +21,22 @@ MAINTAINER= torstenb@FreeBSD.org
ALL_TARGET= default
+# WARNING: this is based on a patch submitted by a user and has not been
+# tested. Use it at your own risk !
+.if defined(USE_MYSQL) && ${USE_MYSQL} == YES
+BUILD_DEPENDS+= ${PREFIX}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql322-client
+POSTFIX_CCARGS+= -DHAS_MYSQL -I${PREFIX}/include/mysql
+POSTFIX_AUXLIBS+= ${PREFIX}/lib/mysql/libmysqlclient.a -lm
+.endif
+
+# WARNING: this is based on a patch submitted by a user and has not been
+# tested. Use it at your own risk !
+.if defined(USE_LDAP) && ${USE_LDAP} == YES
+BUILD_DEPENDS+= ${PREFIX}/lib/libldap.a:${PORTSDIR}/net/openldap
+POSTFIX_CCARGS+= -DHAS_LDAP -I${PREFIX}/include
+POSTFIX_AUXLIBS+= ${PREFIX}/lib/libldap.a ${PREFIX}/lib/liblber.a
+.endif
+
SCRIPTS_ENV+= MAN1="${MAN1}" MAN5="${MAN5}" MAN8="${MAN8}"
MAKE_ENV+= "OPT=${CFLAGS}"