aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix26/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-03-04 15:31:25 +0800
committerleeym <leeym@FreeBSD.org>2003-03-04 15:31:25 +0800
commitea580f144df1f5ab7a4ce6a869d49c5a15e787a7 (patch)
tree6af287f4cd9dd683f9cc9d7335d111bbda2ed998 /mail/postfix26/Makefile
parenta1b7f1fa4c0cb908cc80226e0d02015d96c55f45 (diff)
downloadfreebsd-ports-gnome-ea580f144df1f5ab7a4ce6a869d49c5a15e787a7.tar.gz
freebsd-ports-gnome-ea580f144df1f5ab7a4ce6a869d49c5a15e787a7.tar.zst
freebsd-ports-gnome-ea580f144df1f5ab7a4ce6a869d49c5a15e787a7.zip
Batch building of packages for postfix is failing due to PCRE issues.
PR: 48896 Submitted by: Vivek Khera <khera@kcilink.com>
Diffstat (limited to 'mail/postfix26/Makefile')
-rw-r--r--mail/postfix26/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/mail/postfix26/Makefile b/mail/postfix26/Makefile
index 19822150046a..6e1e8c9a8334 100644
--- a/mail/postfix26/Makefile
+++ b/mail/postfix26/Makefile
@@ -7,11 +7,13 @@
# To pre-select options in batch mode, run make like this:
#
-# make -DBATCH POSTFIX_OPTIONS="DB3 PCRE"
+# make -DBATCH POSTFIX_OPTIONS="DB3 IPv6TLS"
#
# the options are the same names as in the scripts/configure.postfix file.
# POSTFIX_OPTIONS can be set in /etc/make.conf also.
+# NOTE: PCRE is enabled by default unless you specifically disable it.
+
PORTNAME= postfix
PORTVERSION= 2.0.4
PORTEPOCH= 1
@@ -70,6 +72,15 @@ pre-fetch:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
+.if defined(WITHOUT_PCRE)
+POSTFIX_CCARGS+= -DNO_PCRE
+.else
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+POSTFIX_CCARGS+= -DHAS_PCRE -I${LOCALBASE}/include
+POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
+.endif
+
+
post-patch:
(cd ${WRKSRC} && ${MAKE} -f Makefile.init makefiles ${MAKEFILEFLAGS} \
CCARGS="${POSTFIX_CCARGS}" AUXLIBS="${POSTFIX_AUXLIBS}" && \