aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix26
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-11-27 23:48:49 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-11-27 23:48:49 +0800
commitc017f459bceeb3d0abf931140a6caa82aa7d3a80 (patch)
treef48281cd02c92676261f0429ae574ba4bc102087 /mail/postfix26
parenta9b6e342d16e82a9b2a3a09d8db3a9154302e4f9 (diff)
downloadfreebsd-ports-gnome-c017f459bceeb3d0abf931140a6caa82aa7d3a80.tar.gz
freebsd-ports-gnome-c017f459bceeb3d0abf931140a6caa82aa7d3a80.tar.zst
freebsd-ports-gnome-c017f459bceeb3d0abf931140a6caa82aa7d3a80.zip
Add header/body_check warnings command
Bump PORTREVISION Submitted by: osa@freebsd.org.ru
Diffstat (limited to 'mail/postfix26')
-rw-r--r--mail/postfix26/Makefile1
-rw-r--r--mail/postfix26/files/patch-src::cleanup_message.c24
2 files changed, 25 insertions, 0 deletions
diff --git a/mail/postfix26/Makefile b/mail/postfix26/Makefile
index 0191ec4ee57b..9a23d6b607b9 100644
--- a/mail/postfix26/Makefile
+++ b/mail/postfix26/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
PORTVERSION= 20010228.8
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
ftp://ftp.aet.tu-cottbus.de/pub/postfix_tls/%SUBDIR%/ \
diff --git a/mail/postfix26/files/patch-src::cleanup_message.c b/mail/postfix26/files/patch-src::cleanup_message.c
new file mode 100644
index 000000000000..9136591841bf
--- /dev/null
+++ b/mail/postfix26/files/patch-src::cleanup_message.c
@@ -0,0 +1,24 @@
+--- ./src/cleanup/cleanup_message.c.orig Tue Nov 27 16:55:39 2001
++++ ./src/cleanup/cleanup_message.c Tue Nov 27 16:58:43 2001
+@@ -269,6 +269,10 @@
+ state->errs |= CLEANUP_STAT_CONT;
+ } else if (strcasecmp(value, "IGNORE") == 0) {
+ return;
++ } else if (strcasecmp(value, "WARN") == 0) {
++ msg_info("%s: warning: header %.200s; from=<%s> to=<%s>",
++ state->queue_id, header, state->sender,
++ state->recip ? state->recip : "unknown");
+ }
+ }
+ }
+@@ -498,6 +502,10 @@
+ state->errs |= CLEANUP_STAT_CONT;
+ } else if (strcasecmp(value, "IGNORE") == 0) {
+ return;
++ } else if (strcasecmp(value, "WARN") == 0) {
++ msg_info("%s: warning: body %.200s; from=<%s> to=<%s>",
++ state->queue_id, buf, state->sender,
++ state->recip ? state->recip : "unknown");
+ }
+ }
+ }