aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix27/Makefile
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-08-27 05:33:57 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-08-27 05:33:57 +0800
commit633ce6b98596d7334abda998f74568effefdff4c (patch)
tree9780174b4c842940bc352753ba07996ed56b4b96 /mail/postfix27/Makefile
parent5958509e2a257e6ad1c00ed3a623749012c8d5c8 (diff)
downloadfreebsd-ports-gnome-633ce6b98596d7334abda998f74568effefdff4c.tar.gz
freebsd-ports-gnome-633ce6b98596d7334abda998f74568effefdff4c.tar.zst
freebsd-ports-gnome-633ce6b98596d7334abda998f74568effefdff4c.zip
Add hooks to preselect postfix options
Update TLS PR: 42047 Submitted by: maintainer, knu
Diffstat (limited to 'mail/postfix27/Makefile')
-rw-r--r--mail/postfix27/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/mail/postfix27/Makefile b/mail/postfix27/Makefile
index c894d272351f..6b47f15e39d2 100644
--- a/mail/postfix27/Makefile
+++ b/mail/postfix27/Makefile
@@ -5,6 +5,12 @@
# $FreeBSD$
#
+# To pre-select options in batch mode, run make like this:
+#
+# make -DBATCH POSTFIX_OPTIONS="DB3 PCRE"
+#
+# the options are the same names as in the scripts/configure.postfix file
+
PORTNAME= postfix
PORTVERSION= 1.1.11
PORTEPOCH= 1
@@ -46,6 +52,7 @@ MAKEFILEFLAGS+= OPT="${CFLAGS}"
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
MKDIR="${MKDIR}" \
+ POSTFIX_OPTIONS="${POSTFIX_OPTIONS}"
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.postfix