aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix28/Makefile
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2007-04-05 01:18:18 +0800
committermnag <mnag@FreeBSD.org>2007-04-05 01:18:18 +0800
commit4564fa7a20f2a0e826acce22c00c3d417dd5814c (patch)
tree618e895b855fa618537d8e383221cc4787b88a8c /mail/postfix28/Makefile
parent189dfdd0ab3d58e1ea99f651d1e0ccde42452302 (diff)
downloadfreebsd-ports-gnome-4564fa7a20f2a0e826acce22c00c3d417dd5814c.tar.gz
freebsd-ports-gnome-4564fa7a20f2a0e826acce22c00c3d417dd5814c.tar.zst
freebsd-ports-gnome-4564fa7a20f2a0e826acce22c00c3d417dd5814c.zip
* mail/postfix
- Update to 2.4.0 - Install qshape as default - Install test programs in PREFIX/bin instead of PREFIX/sbin to respect hier(7) * mail/postfix23 - Repocopied from mail/postfix to reflect 2.3.x version [1] * mail/Makefile - Add postfix23 Approved by: vivek___khera.org (maintainer) Repocopy by: marcus [1]
Diffstat (limited to 'mail/postfix28/Makefile')
-rw-r--r--mail/postfix28/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/mail/postfix28/Makefile b/mail/postfix28/Makefile
index 9603dacaaf4d..71faccb05b84 100644
--- a/mail/postfix28/Makefile
+++ b/mail/postfix28/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.3.8
+PORTVERSION= 2.4.0
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -23,7 +23,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= vivek@khera.org
COMMENT= A secure alternative to widely-used Sendmail
-CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-24-9].* postfix-current-2.* \
+CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-35-9].* postfix-current-2.* \
sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
USE_SUBMAKE= yes
@@ -59,7 +59,8 @@ OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
TEST "SMTP/LMTP test server and generator" ${STATUS_Test}
MAN1= postalias.1 postcat.1 postconf.1 postdrop.1 postfix.1 postkick.1 \
- postlock.1 postlog.1 postmap.1 postqueue.1 postsuper.1 sendmail.1
+ postlock.1 postlog.1 postmap.1 postqueue.1 postsuper.1 sendmail.1 \
+ qshape.1
MAN5= access.5 aliases.5 bounce.5 canonical.5 cidr_table.5 generic.5 \
header_checks.5 ldap_table.5 master.5 mysql_table.5 nisplus_table.5 \
@@ -199,6 +200,7 @@ _REQUIRE+= ypserv
.endif
.if defined(WITH_VDA)
+BROKEN= Does not apply. Waiting to a new version
PATCH_SITES+= http://vda.sourceforge.net/VDA/
PATCHFILES+= postfix-2.3.7-vda.patch.gz
PATCH_DIST_STRIP= -p1
@@ -299,8 +301,11 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/auxiliary/rmail/rmail ${PREFIX}/bin/rmail
+ ${INSTALL_SCRIPT} ${WRKSRC}/auxiliary/qshape/qshape.pl ${PREFIX}/bin/qshape
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/qshape.1 ${MANPREFIX}/man/man1
+
.for f in ${BINTEST}
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${f} ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${f} ${PREFIX}/bin
.endfor
.for f in ${MANTEST}
${INSTALL_MAN} ${WRKSRC}/man/man1/${f} ${MANPREFIX}/man/man1