aboutsummaryrefslogtreecommitdiffstats
path: root/mail/procmail
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-10 21:05:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-10 21:05:12 +0800
commitf8e4b8ddfa34b5e00ed0bfa14bd7ec0037116ae9 (patch)
treeb21882297b2b13a6e147bb5424159df4c55f75bd /mail/procmail
parent436d1c0fcd5f2c7ace3152f1d2e04ec0bfd38aa4 (diff)
downloadfreebsd-ports-gnome-f8e4b8ddfa34b5e00ed0bfa14bd7ec0037116ae9.tar.gz
freebsd-ports-gnome-f8e4b8ddfa34b5e00ed0bfa14bd7ec0037116ae9.tar.zst
freebsd-ports-gnome-f8e4b8ddfa34b5e00ed0bfa14bd7ec0037116ae9.zip
- Skip interactive input of additional directories for lock test
- Remove BATCH/IS_INTERACTIVE section in Makefile PR: ports/153409 Submitted by: Craig Leres <leres@ee.lbl.gov>
Diffstat (limited to 'mail/procmail')
-rw-r--r--mail/procmail/Makefile8
-rw-r--r--mail/procmail/files/patch-src:autoconf17
2 files changed, 13 insertions, 12 deletions
diff --git a/mail/procmail/Makefile b/mail/procmail/Makefile
index 66e09c66a3bb..b7d4c35f9fe1 100644
--- a/mail/procmail/Makefile
+++ b/mail/procmail/Makefile
@@ -33,14 +33,6 @@ MAKE_JOBS_UNSAFE= yes
#PATCH_DIST_STRIP=-p
#.endif
-# It asks for list of directories to do test for file locking
-# (defaults to /tmp and ".", so return should suffice in most cases).
-.if defined(BATCH) # handled in patch-aa
-MAKE_ARGS+= -DBATCH
-.else
-IS_INTERACTIVE= yes
-.endif
-
INSTALL_TARGET= install-suid install.man
MAN1= procmail.1 formail.1 lockfile.1
diff --git a/mail/procmail/files/patch-src:autoconf b/mail/procmail/files/patch-src:autoconf
index 964a015185ed..ef615cb599ba 100644
--- a/mail/procmail/files/patch-src:autoconf
+++ b/mail/procmail/files/patch-src:autoconf
@@ -1,6 +1,16 @@
---- src/autoconf.ORI Sun Oct 30 10:01:45 2005
-+++ src/autoconf Sun Oct 30 10:03:56 2005
-@@ -978,6 +978,7 @@
+--- src/autoconf.orig 2001-09-10 21:55:46.000000000 -0700
++++ src/autoconf 2010-12-23 11:53:07.000000000 -0800
+@@ -230,7 +230,8 @@
+ echo ""
+ if test -z "$LOCKINGTEST"
+ then
+- read b
++ #read b
++ b=""
+ elif test dummy = "$LOCKINGTEST"
+ then
+ b=""
+@@ -977,6 +978,7 @@
echo 'Checking realloc implementation'
@@ -8,4 +18,3 @@
if $MAKE _autotst >$DEVNULL 2>&1
test -f _autotst
then
-