aboutsummaryrefslogtreecommitdiffstats
path: root/mail/procmail
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-08-25 17:27:58 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-08-25 17:27:58 +0800
commit96f49438dd6005e65c4b00014a4ee90bbfb42535 (patch)
tree083f6754341cf9b7c649fb2039012ffb71fd6c9a /mail/procmail
parent3f5f8187d08d285bfce3d7d6042d61b6fef47dd1 (diff)
downloadfreebsd-ports-gnome-96f49438dd6005e65c4b00014a4ee90bbfb42535.tar.gz
freebsd-ports-gnome-96f49438dd6005e65c4b00014a4ee90bbfb42535.tar.zst
freebsd-ports-gnome-96f49438dd6005e65c4b00014a4ee90bbfb42535.zip
- Convert to new options framework
- Use PLIST_FILES, PORTDOCS and PORTEXAMPLES instead of PLIST - Cleanup Makefile header
Diffstat (limited to 'mail/procmail')
-rw-r--r--mail/procmail/Makefile25
-rw-r--r--mail/procmail/pkg-plist22
2 files changed, 13 insertions, 34 deletions
diff --git a/mail/procmail/Makefile b/mail/procmail/Makefile
index 71e00673c869..9a59b2b1d49b 100644
--- a/mail/procmail/Makefile
+++ b/mail/procmail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: procmail
-# Date created: 24 September 1994
-# Whom: adam
-#
+# Created by: adam
# $FreeBSD$
-#
PORTNAME= procmail
PORTVERSION= 3.22
@@ -21,26 +17,31 @@ MASTER_SITES= ftp://ftp.ucsb.edu/pub/mirrors/procmail/ \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Local mail delivery agent
+OPTIONS_SET= DOCS EXAMPLES
+
INSTALL_TARGET= install-suid install.man
MAKE_JOBS_UNSAFE= yes
-DOCS= FAQ FEATURES HISTORY KNOWN_BUGS README
-EXAMPLES= 1procmailrc 1rmail 2procmailrc 2rmail 3procmailrc 3rmail \
- advanced dirname forward local_procmail_lmtp.m4 mailstat
MAN1= formail.1 lockfile.1 procmail.1
MAN5= procmailex.5 procmailrc.5 procmailsc.5
+PLIST_FILES= bin/formail bin/lockfile bin/mailstat bin/procmail
+PORTDOCS= FAQ FEATURES HISTORY KNOWN_BUGS README
+PORTEXAMPLES= 1procmailrc 1rmail 2procmailrc 2rmail 3procmailrc 3rmail \
+ advanced dirname forward local_procmail_lmtp.m4 mailstat
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/config.h
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}/
- cd ${WRKSRC}/examples/ && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}/
+ cd ${WRKSRC}/examples/ && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}/
.endif
.include <bsd.port.mk>
diff --git a/mail/procmail/pkg-plist b/mail/procmail/pkg-plist
deleted file mode 100644
index ea0a7e5d0e53..000000000000
--- a/mail/procmail/pkg-plist
+++ /dev/null
@@ -1,22 +0,0 @@
-bin/formail
-bin/lockfile
-bin/mailstat
-bin/procmail
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/FEATURES
-%%PORTDOCS%%%%DOCSDIR%%/HISTORY
-%%PORTDOCS%%%%DOCSDIR%%/KNOWN_BUGS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/1procmailrc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/1rmail
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/2procmailrc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/2rmail
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/3procmailrc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/3rmail
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/advanced
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dirname
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/forward
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/local_procmail_lmtp.m4
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailstat
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%