aboutsummaryrefslogtreecommitdiffstats
path: root/mail/proxsmtp/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-05-04 22:42:03 +0800
committerpav <pav@FreeBSD.org>2005-05-04 22:42:03 +0800
commita57b2431d5f8fa45ebc3ddc27de1b16c9c30a118 (patch)
tree725a7b7a5a7204bf210f94b61661f4fb82e7da04 /mail/proxsmtp/Makefile
parent57a79e496b4f2a753e11a8e142cf1657b89c7281 (diff)
downloadfreebsd-ports-gnome-a57b2431d5f8fa45ebc3ddc27de1b16c9c30a118.tar.gz
freebsd-ports-gnome-a57b2431d5f8fa45ebc3ddc27de1b16c9c30a118.tar.zst
freebsd-ports-gnome-a57b2431d5f8fa45ebc3ddc27de1b16c9c30a118.zip
ProxSMTP is a flexible tool that allows you to reject, change or log
email based on arbitrary critera. It accepts SMTP connections and forwards the SMTP commands and responses to another SMTP server. You need to be able to write the filtering scripts that integrate it with your particular needs. PR: ports/80596 Submitted by: Dario Freni <saturnero@gufi.org>
Diffstat (limited to 'mail/proxsmtp/Makefile')
-rw-r--r--mail/proxsmtp/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/mail/proxsmtp/Makefile b/mail/proxsmtp/Makefile
new file mode 100644
index 000000000000..029fb002445d
--- /dev/null
+++ b/mail/proxsmtp/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: proxsmtp
+# Date created: 2005-05-03
+# Whom: Dario Freni <saturnero@gufi.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= proxsmtp
+PORTVERSION= 1.2.1
+CATEGORIES= mail security
+MASTER_SITES= http://memberwebs.com/nielsen/software/proxsmtp/
+
+MAINTAINER= saturnero@gufi.org
+COMMENT= A flexible SMTP filter which can act also as trasparent proxy
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_RC_SUBR= proxsmtpd.sh
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+MAN5= proxsmtpd.conf.5
+MAN8= proxsmtpd.8
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS}," ${WRKSRC}/configure
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/doc/proxsmtpd.conf ${PREFIX}/etc/proxsmtpd.conf-sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>