aboutsummaryrefslogtreecommitdiffstats
path: root/mail/py-milter/files
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-04-29 21:20:26 +0800
committerarved <arved@FreeBSD.org>2004-04-29 21:20:26 +0800
commitf5588a4c764defe23c5bd1f580a393b2a34edc97 (patch)
tree16d9f2b797f0bfc12536b6d21f64fc05fe75abd5 /mail/py-milter/files
parenta548dd80dd0f688134513f06d3729b32368f46fe (diff)
downloadfreebsd-ports-gnome-f5588a4c764defe23c5bd1f580a393b2a34edc97.tar.gz
freebsd-ports-gnome-f5588a4c764defe23c5bd1f580a393b2a34edc97.tar.zst
freebsd-ports-gnome-f5588a4c764defe23c5bd1f580a393b2a34edc97.zip
Upgrade to 0.6.9
PR: 65907 Submitted by: Georg Graf
Diffstat (limited to 'mail/py-milter/files')
-rw-r--r--mail/py-milter/files/patch-aa10
-rw-r--r--mail/py-milter/files/patch-ab28
2 files changed, 5 insertions, 33 deletions
diff --git a/mail/py-milter/files/patch-aa b/mail/py-milter/files/patch-aa
index 69dfad11885c..42a0119d5e23 100644
--- a/mail/py-milter/files/patch-aa
+++ b/mail/py-milter/files/patch-aa
@@ -1,11 +1,11 @@
---- setup.py.orig Tue Jul 1 15:36:23 2003
-+++ setup.py Tue Jul 1 15:36:54 2003
-@@ -2,7 +2,7 @@
+--- setup.py Tue Apr 20 00:15:07 2004
++++ setup.py Fri Apr 23 10:59:26 2004
+@@ -3,7 +3,7 @@
from distutils.core import setup, Extension
# FIXME: on some versions of sendmail, smutil is renamed to sm
-libs = ["milter", "smutil"]
+libs = ["milter"]
- setup(name = "milter", version = "0.5.5",
- description="Python interface to sendmail-8.1x milter API",
+ # patch distutils if it can't cope with the "classifiers" or
+ # "download_url" keywords
diff --git a/mail/py-milter/files/patch-ab b/mail/py-milter/files/patch-ab
deleted file mode 100644
index c8d868bf8b41..000000000000
--- a/mail/py-milter/files/patch-ab
+++ /dev/null
@@ -1,28 +0,0 @@
---- miltermodule.c.orig Tue Jun 24 21:57:04 2003
-+++ miltermodule.c Wed Sep 24 15:30:04 2003
-@@ -110,6 +110,7 @@
-
- #include <pthread.h>
- #include <netinet/in.h>
-+#include <arpa/inet.h>
- #include <Python.h>
- #include <libmilter/mfapi.h>
-
-@@ -503,7 +504,7 @@
- static PyObject *
- makeip6addr(struct sockaddr_in6 *addr) {
- char buf[100]; /* must be at least INET6_ADDRSTRLEN + 1 */
-- char * s;
-+ const char * s;
- s = inet_ntop(AF_INET6, &addr->sin6_addr, buf, sizeof(buf));
- if( s )
- return PyString_FromString(buf);
-@@ -987,7 +988,7 @@
- static char milter_quarantine__doc__[] =
- "quarantine(string) -> None\n\
- Place the message in quarantine. A string with a description of the reason\n\
--is the only argument.
-+is the only argument.\
- ";
-
- static PyObject *