aboutsummaryrefslogtreecommitdiffstats
path: root/mail/py-spambayes/Makefile
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2012-06-18 07:48:10 +0800
committersylvio <sylvio@FreeBSD.org>2012-06-18 07:48:10 +0800
commit8e82569341b5c8b9329b4f71cbe684c04a4a95f9 (patch)
treeddac92cea26d90c496a661731e70c7e1deac5140 /mail/py-spambayes/Makefile
parentd08375b40d2d0e107d736e5683e1a78469d08bd4 (diff)
downloadfreebsd-ports-gnome-8e82569341b5c8b9329b4f71cbe684c04a4a95f9.tar.gz
freebsd-ports-gnome-8e82569341b5c8b9329b4f71cbe684c04a4a95f9.tar.zst
freebsd-ports-gnome-8e82569341b5c8b9329b4f71cbe684c04a4a95f9.zip
- Update to 1.1b1
- Pass maintainership to submitter - Point to CHEESESHOP - Add LICENSE - Reorder USE_* variables - Remove uneeded PY*_{EGG,PKGNAME} variables - Update and sort pkg-plist PR: ports/169097 Submitted by: koobs <koobs.freebsd@gmail.com>
Diffstat (limited to 'mail/py-spambayes/Makefile')
-rw-r--r--mail/py-spambayes/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/mail/py-spambayes/Makefile b/mail/py-spambayes/Makefile
index 78b97cbc06dd..1a4b407fc65b 100644
--- a/mail/py-spambayes/Makefile
+++ b/mail/py-spambayes/Makefile
@@ -6,26 +6,28 @@
#
PORTNAME= spambayes
-PORTVERSION= 1.1a6
+PORTVERSION= 1.1b1
CATEGORIES= mail python
-MASTER_SITES= SF
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= koobs.freebsd@gmail.com
COMMENT= A Bayesian anti-spam filter written in Python
+LICENSE= PSFL
+
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb \
${PYTHON_PKGNAMEPREFIX}dns>=2.0:${PORTSDIR}/dns/py-dns \
${PYTHON_PKGNAMEPREFIX}lockfile>=0.2:${PORTSDIR}/devel/py-lockfile
-USE_PYDISTUTILS=easy_install
-PYDISTUTILS_PKGNAME= ${PORTNAME}
-PYEASYINSTALL_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
USE_PYTHON= 2.6+
+USE_PYDISTUTILS=easy_install
USE_RC_SUBR= pyspamd
+
LOCALSTATDIR?= /var/db/spambayes
DBDIR?= ${LOCALSTATDIR}/dbs
CACHEDIR?= ${LOCALSTATDIR}/cache
+
PLIST_SUB+= LOCALSTATDIR=${LOCALSTATDIR} \
DBDIR=${DBDIR} \
CACHEDIR=${CACHEDIR}