aboutsummaryrefslogtreecommitdiffstats
path: root/mail/pygmy/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-05-05 05:25:07 +0800
committersobomax <sobomax@FreeBSD.org>2001-05-05 05:25:07 +0800
commitb168e3046ef1066791fa96cbbbdcfc373243817c (patch)
treed1bb9819cae51f0dbd9890506b6123fc73d24b04 /mail/pygmy/Makefile
parent38647a822abb220343a463e48eed5ef396077c2f (diff)
downloadfreebsd-ports-gnome-b168e3046ef1066791fa96cbbbdcfc373243817c.tar.gz
freebsd-ports-gnome-b168e3046ef1066791fa96cbbbdcfc373243817c.tar.zst
freebsd-ports-gnome-b168e3046ef1066791fa96cbbbdcfc373243817c.zip
- Fix on python2.1;
- install source .py files in addition to the byte-compiled versions.
Diffstat (limited to 'mail/pygmy/Makefile')
-rw-r--r--mail/pygmy/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/mail/pygmy/Makefile b/mail/pygmy/Makefile
index 5f3a8b5f63ad..850cd643022d 100644
--- a/mail/pygmy/Makefile
+++ b/mail/pygmy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pygmy
PORTVERSION= 0.5.5
+PORTREVISION= 1
CATEGORIES= mail python gnome
MASTER_SITES= http://pygmy.sourceforge.net/
@@ -25,7 +26,9 @@ do-configure:
do-install:
${MKDIR} ${PREFIX}/share/pygmy/icons
- ${INSTALL_DATA} ${WRKSRC}/*.pyo ${WRKSRC}/*.pyc ${PREFIX}/share/pygmy
+.for ext in py pyc pyo
+ ${INSTALL_DATA} ${WRKSRC}/*.${ext} ${PREFIX}/share/pygmy
+.endfor
${INSTALL_DATA} ${WRKSRC}/icons/* ${PREFIX}/share/pygmy/icons
${INSTALL_DATA} ${WRKSRC}/pygmy ${PREFIX}/share/pygmy
@printf "#!/bin/sh\n${PYTHON_CMD} ${PREFIX}/share/pygmy/pygmy" > \