aboutsummaryrefslogtreecommitdiffstats
path: root/mail/pymsgauth/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-10-14 21:41:29 +0800
committerijliao <ijliao@FreeBSD.org>2002-10-14 21:41:29 +0800
commitb68aa2434b6c59ea0f89fab1990ef41c839ec4cc (patch)
treeb5d81d9562aa466c0eace762b61ecdc45fb4d042 /mail/pymsgauth/Makefile
parentdd3538c1d0a9246f1813d889fe4aff0e5cbea6eb (diff)
downloadfreebsd-ports-gnome-b68aa2434b6c59ea0f89fab1990ef41c839ec4cc.tar.gz
freebsd-ports-gnome-b68aa2434b6c59ea0f89fab1990ef41c839ec4cc.tar.zst
freebsd-ports-gnome-b68aa2434b6c59ea0f89fab1990ef41c839ec4cc.zip
- Always install sample config file (i.e. even if NOPORTDOCS is defined)
- Do not install yet another copy of GPL - Cleanup Makefile - Sort pkg-plist PR: 44025 Submitted by: maintainer
Diffstat (limited to 'mail/pymsgauth/Makefile')
-rw-r--r--mail/pymsgauth/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/mail/pymsgauth/Makefile b/mail/pymsgauth/Makefile
index 2dfc54983fb7..0b735a8fe975 100644
--- a/mail/pymsgauth/Makefile
+++ b/mail/pymsgauth/Makefile
@@ -17,7 +17,7 @@ USE_REINPLACE= yes
NO_BUILD= yes
-DOCS= BUGS CHANGELOG COPYING pymsgauth.txt pymsgauth.html
+DOCS= BUGS CHANGELOG pymsgauth.txt pymsgauth.html
post-patch:
${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
@@ -28,16 +28,14 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/pymsgauth-* ${PYTHON_SITELIBDIR}
${LN} -sf ${PYTHON_SITELIBDIR}/pymsgauth-* ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/*.py ${PYTHON_SITELIBDIR}
-
.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/pymsgauthrc-example ${EXAMPLESDIR}
-
- ${MKDIR} ${DOCSDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/pymsgauthrc-example ${EXAMPLESDIR}
+ @${SED} -e 's,__EXAMPLES__,${EXAMPLESDIR},' ${PKGMESSAGE}
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's,__EXAMPLES__,${EXAMPLESDIR},'
.include <bsd.port.mk>