aboutsummaryrefslogtreecommitdiffstats
path: root/mail/pymsgauth/Makefile
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2002-10-07 23:10:24 +0800
committernbm <nbm@FreeBSD.org>2002-10-07 23:10:24 +0800
commitc648cde35d9f85cdfaf9debd7b8545bd3379ed30 (patch)
treebd78cfcb82a86b09f3e7c35010234093273cb5ef /mail/pymsgauth/Makefile
parenta5dd8fed6a716ab07a8613cdeaffe970cb5aaba6 (diff)
downloadfreebsd-ports-gnome-c648cde35d9f85cdfaf9debd7b8545bd3379ed30.tar.gz
freebsd-ports-gnome-c648cde35d9f85cdfaf9debd7b8545bd3379ed30.tar.zst
freebsd-ports-gnome-c648cde35d9f85cdfaf9debd7b8545bd3379ed30.zip
Add pymsgauth 2.0.0, a toolkit for dealing with qsecretary confirmation
notices. PR: 41672 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Diffstat (limited to 'mail/pymsgauth/Makefile')
-rw-r--r--mail/pymsgauth/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/mail/pymsgauth/Makefile b/mail/pymsgauth/Makefile
new file mode 100644
index 000000000000..2dfc54983fb7
--- /dev/null
+++ b/mail/pymsgauth/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: pymsgauth
+# Date created: 12 Aug 2002
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pymsgauth
+PORTVERSION= 2.0.0
+CATEGORIES= mail python
+MASTER_SITES= http://www.qcc.ca/~charlesc/software/pymsgauth/
+
+MAINTAINER= sergei@kolobov.com
+
+USE_PYTHON= yes
+USE_REINPLACE= yes
+
+NO_BUILD= yes
+
+DOCS= BUGS CHANGELOG COPYING pymsgauth.txt pymsgauth.html
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
+ ${WRKSRC}/pymsgauth-*
+ ${RM} ${WRKSRC}/pymsgauth-*.bak
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pymsgauth-* ${PYTHON_SITELIBDIR}
+ ${LN} -sf ${PYTHON_SITELIBDIR}/pymsgauth-* ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/*.py ${PYTHON_SITELIBDIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/pymsgauthrc-example ${EXAMPLESDIR}
+
+ ${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's,__EXAMPLES__,${EXAMPLESDIR},'
+.include <bsd.port.mk>