aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmail-conf
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-04-03 09:36:15 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-04-03 09:36:15 +0800
commit9b6c350223861dd04c4e90991c7ad7e9df5f0156 (patch)
tree3706248310ffcc31a7e3643b56d22dae8fa8e49b /mail/qmail-conf
parenta3ea4e44e7500aa9b9afb7103cbc7c365247f0fe (diff)
downloadfreebsd-ports-gnome-9b6c350223861dd04c4e90991c7ad7e9df5f0156.tar.gz
freebsd-ports-gnome-9b6c350223861dd04c4e90991c7ad7e9df5f0156.tar.zst
freebsd-ports-gnome-9b6c350223861dd04c4e90991c7ad7e9df5f0156.zip
- Support staging
This uses similar methods as dns/djbdns from r346769 and r349241 - Add qmail as a RUN_DEPENDS so that it properly owns the /var/qmail and /var/qmail/bin directories.
Diffstat (limited to 'mail/qmail-conf')
-rw-r--r--mail/qmail-conf/Makefile18
-rw-r--r--mail/qmail-conf/pkg-plist1
2 files changed, 14 insertions, 5 deletions
diff --git a/mail/qmail-conf/Makefile b/mail/qmail-conf/Makefile
index a2f3d7c373ab..944f64b5cdb0 100644
--- a/mail/qmail-conf/Makefile
+++ b/mail/qmail-conf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qmail-conf
PORTVERSION= 0.60
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://www.din.or.jp/~ushijima/qmail-conf/ \
http://cr.yp.to/djbdns/
@@ -14,15 +14,15 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Configure various qmail services to run under daemontools
-USES= qmail:vars
-NO_STAGE= yes
+USES= qmail:run
-ALL_TARGET= it
+ALL_TARGET= prog
INSTALL_TARGET= setup check
RESTRICTED= borrows code from djbdns, thus falls under the same restrictions as dns/djbdns
PREFIX?= ${QMAIL_PREFIX}
+NO_PREFIX_RMDIR=yes
NO_MTREE= yes
@@ -42,4 +42,14 @@ post-patch:
pre-build:
@(cd ${WRKSRC} && ${MAKE} djbdns=${DJBDNS_NAME} -f Makefile.ini)
+# Do a dance to stage and keep out of resulting binaries (see r346769
+# and r349241)
+pre-install:
+ @${MV} -f ${WRKSRC}/conf-qmail ${WRKSRC}/conf-qmail.sav
+ @${ECHO_CMD} "${STAGEDIR}${QMAIL_PREFIX}" > ${WRKSRC}/conf-qmail
+ @cd ${WRKSRC} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o
+ @cd ${WRKSRC} ; ${MAKE_CMD} install instcheck
+ @${TOUCH} ${WRKSRC}/*-conf
+ @${MV} -f ${WRKSRC}/conf-qmail.sav ${WRKSRC}/conf-qmail
+
.include <bsd.port.mk>
diff --git a/mail/qmail-conf/pkg-plist b/mail/qmail-conf/pkg-plist
index fa51d2461032..2b3f2532bff9 100644
--- a/mail/qmail-conf/pkg-plist
+++ b/mail/qmail-conf/pkg-plist
@@ -3,5 +3,4 @@ bin/qmail-pop3d-conf
bin/qmail-qmqpd-conf
bin/qmail-qmtpd-conf
bin/qmail-smtpd-conf
-@dirrmtry bin
@dirrmtry service