aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmail-mysql/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-05-10 22:31:29 +0800
committersem <sem@FreeBSD.org>2005-05-10 22:31:29 +0800
commitcd2c4e00181bb1350bba70dd4c426f4d0aa124a3 (patch)
treeded1ef83de364d0f15931b60f6bf4b808a492694 /mail/qmail-mysql/Makefile
parent5550194a73da1e28c4aa92afe3d02f5bf729e704 (diff)
downloadfreebsd-ports-gnome-cd2c4e00181bb1350bba70dd4c426f4d0aa124a3.tar.gz
freebsd-ports-gnome-cd2c4e00181bb1350bba70dd4c426f4d0aa124a3.tar.zst
freebsd-ports-gnome-cd2c4e00181bb1350bba70dd4c426f4d0aa124a3.zip
- Transfer all work to MASTER port and make slave ports easier
- Use only one pkg-plist and use PLIST_SUB - Use DOCSDIR intead of DOCDIR - OPTIONS'ify - Remove WITH_PRESERVE_CONFIG_FILES knob and detect automatically when is need to create it. - Add $FreeBSD$ tag to pkg-plist and pkg-install - Fix error on enable-qmail script - Remove MASTER_SITE_QMAIL definition from Makefile since it's defined on bsd.sites.mk - Add a new option to don't create rc.d/qmail.sh - Add rc.d/qmail.sh to pkg-plist when necessary PR: ports/80833 Submitted by: maintainer Thanks to: novel, Joao Ricardo P. Mendes <joao@redepegasus.com.br>
Diffstat (limited to 'mail/qmail-mysql/Makefile')
-rw-r--r--mail/qmail-mysql/Makefile34
1 files changed, 5 insertions, 29 deletions
diff --git a/mail/qmail-mysql/Makefile b/mail/qmail-mysql/Makefile
index 981ce9cc1702..550c00a3bdce 100644
--- a/mail/qmail-mysql/Makefile
+++ b/mail/qmail-mysql/Makefile
@@ -7,45 +7,21 @@
PORTNAME= qmail
PORTVERSION= ${QMAIL_VERSION}.${MYSQL_PATCH_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
PKGNAMESUFFIX= -mysql
-PATCH_SITES+= http://iain.cx/unix/qmail/download/:mysql
-PATCHFILES+= qmail-mysql-${MYSQL_PATCH_VERSION}.patch:mysql
-
MAINTAINER= freebsd@galle.com.br
COMMENT= A SECURE, reliable, and FAST MTA for UNIX systems WITH MySQL support
-USE_MYSQL= yes
-USE_REINPLACE= yes
-
-# patches from the master port that brake this one are now allowed
-MAIN_QMAIL_PORT_WITH_QMAILQUEUE_PATCH_BARRIER= yes
-
MYSQL_PATCH_VERSION= 1.1.8
-# Using default from master port, i.e., /var/qmail
-PREFIX?= ${QMAIL_PORT_PREFIX}
+SLAVE_MYSQL= yes
-.if !defined(_PREMKINCLUDED)
-.include <bsd.port.pre.mk>
-.endif
+USE_MYSQL= yes
-# Local overrides
MASTERDIR= ${.CURDIR}/../qmail
-PKGDIR_LOCAL= ${.CURDIR}
-DESCR= ${PKGDIR_LOCAL}/pkg-descr
-PKGMESSAGE= ${PKGDIR_LOCAL}/pkg-message
-
-QMAIL_PORT_PREFIX!= cd ${MASTERDIR} && ${MAKE} -V PREFIX
-
-# Yet anther ugly hack (works due to code inside the main qmail port)
-slaveport-post-patch: qmail-mysql-post-patch
-
-qmail-mysql-post-patch:
- @${REINPLACE_CMD} \
- 's|/opt/mysql|${LOCALBASE}|' \
- ${WRKSRC}/Makefile
+DESCR= ${.CURDIR}/pkg-descr
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
.include "${MASTERDIR}/Makefile"